Chevy Impala SS Forum banner

1 - 3 of 3 Posts
E

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Well, the car used to wander to the left a lot.
So I took a trip down to the front end shop after I put my SS springs and SS wheels with brand new BFG G-Force KDWS tires on (on my previously stock 95 9c1)...
Got my alignment done, all's good. Inspect my tires 2 months later, and my passenger front tire is completely bald on the inner edge. Took it back to him, and he worked on it again. Said he "knocked some shims out" and to "come back when you get new tires"....

What is going on here? He aligned it, but it roasted my tire... is my suspension shot? Because he didn't mention anything when we asked.
Thanks


Also, my front suspension is ridiculously loud. It makes weird noise (popping, creaking, groaning) when slowing down, when turning wheel while going slowly, while accelerating. Very annoying, makes the car look like a piece of garbage :(
 
A

·
Guest
Joined
·
0 Posts
Discussion Starter #2
OK, I'll ask the standard question I always ask here ;)

WHAT are your alignment specs RIGHT NOW?

Without that, tough to tell what is going on here.....
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Is the Alignment shop reputable? I'd think he would check your f.e. before he even attempted to align your car. He could see what, if any, components are bad and tell you that your car wont hold alignment if you dont replace certain parts.

If it is the case, a f.e. rebuild would be like a new mod. You would feel the difference night and day. You would most likely get those squeaks/groans out. You also have to make sure you keep everything greased up.

As for all the creaks, I had that solved with the rebuild. However, the rear end also made a lot of noise. On launches, the car sounded like it was a bag of nuts & bolts. Changed my LCA's and sway bars and it solved that problem.
 
1 - 3 of 3 Posts
Top