Chevy Impala SS Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
909 Posts
Discussion Starter #1
Had this system on two different b-body wagons and I've never had this issue before today, but it only takes once to make you see the light.

Driving home today in ATL and it was an absolute monsoon. I mean, I grew up in Florida and I've never seen it rain that hard, for that long. Reports on the news said we got 4" in an hour. And I was stuck driving home for most of it. After about 50 minutes of slow-going city-streets and avoiding the lakes that were popping up all over the roads, I turned into my neighborhood and the car sputtered and coughed and popped a code. Laid off the gas, and puttered her home. I had previously had issues with water in the RAISS pan, so I had drilled little drain holes in the corner to let it drain. Had I not done this, I'd have run the risk of doing a lot more damage. As it is, the filter was completely soaked through, and the engine pulled the water through to the MAF. I have a spare of both so the car was back on the road almost immediately, but I'll be pulling over from now on in a hard rain.

I've driven the car through hundreds and hundreds of rain storms and never had an issue. Even a few frog-chokers. Today was an oddball deluge, but thought I'd let folks know what can happen.
 

·
Registered
Joined
·
1,461 Posts
Would wrapping your airfilter inside one of those Baja1000-type
prefilters
be of any help at all?

Somehow I doubt an
ITG MaxoGen
or an
aFe
airfilter would provide much defence against H20, without the sandsock.

At least you didn't have one of those 'elephant trunks' that inhale from under the radiator.

Also, have you done the Opti-condom, or anything else to make your Opti-Spark more water resistant?
 

·
Premium Member
Joined
·
909 Posts
Discussion Starter #3 (Edited)
I actually already run a pre-filter 'sock' on there, and it just pulled the water right through it. Thx for the link to the AFE page - I need a new filter anyway, so I may give them a shot.

Edit: Regarding the opti, I have long said that the hysteria surrounding the opti's tolerance of water is way, way overblown. I am running a stock GM opti and the only thing I did to it was locktite the rotor, and gooped the o-ring between the cap and body with dielectric grease, and greased all the boots. Never had an issue. My suspicion has long been that people with water in the optis either had a crack in the cap somewhere, loose cap screws, or it just wasn't sealed up correctly.
 

·
Premium Member
Joined
·
909 Posts
Discussion Starter #5
Dan

Does the Suncoast hood have the rubber seal along the front like stock hood?
The hood doesnt, but the RAISS does. It has a gasket/seal that sits in a groove on the underside of the nostrils on the hood - sealing the RAISS to the hood. You know, maybe putting a seal on the front of it wouldn't be a bad idea...
 

·
Registered
Joined
·
8,459 Posts
I don't have a RAISS nor a Suncoast hood but in looking at pics of the RAISS....appears the forward metal housing points down allowing air from "grill" up into the intake

That grill would let quite a bit of rain in especially while driving I would think. Maybe not so much in a moderate rain but under the deluge OP experienced, rain certainly got in and corrupted MAF readings.

I suspect just drying everything out would resolve any drivability problems

I remember back when there were "snorkel" intakes that put the cone filter down by the front DS wheel well and people who went through water high enough to get to bumper basically submerged the air filter typically causing engine to shut off from the H20 inhale

Guess some CAI's can be vulnerable to heavy rain so proceed with caution in those conditions

I guess the open air nostrils of the Suncoast also let moisture in also
 

·
Registered
Joined
·
6,742 Posts
Suncoast hoods have a drip edge,and gutter that drain water to forward corners of hood.
 
1 - 7 of 7 Posts
Top