Chevy Impala SS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
370 Posts
Discussion Starter · #1 ·
i replaced my water pump yesterday and installed everything back and when i start the car it had a small leak where the coolant temp sensor is...any help?
 

·
Premium Member
Joined
·
6,706 Posts
Did you use plumber's tape or thread sealant on the threads of the temperature sensor?
 

·
Premium Member
Joined
·
6,706 Posts
You can get the tape from a hardware store, Walmart, lots of places I'd imagine...or you can get the sealant paste from an autoparts store, can't say for certain if they'll have the tape or not but either product will do.

Just have to use enough, not sure how else to describe it but it's just there to fill in the threads better and prevent the water/coolant from flowing past.
 

·
Registered
Joined
·
370 Posts
Discussion Starter · #5 ·
You can get the tape from a hardware store, Walmart, lots of places I'd imagine...or you can get the sealant paste from an autoparts store, can't say for certain if they'll have the tape or not but either product will do.

Just have to use enough, not sure how else to describe it but it's just there to fill in the threads better and prevent the water/coolant from flowing past.
Thanks man your info was very helpful i appreciate it
 

·
Registered
Joined
·
576 Posts
Since you've already refilled your coolant system, the plumbers tape would be your best bet. Have an assistant ready to apply the tape on the coolant temp sensor threads while you plug the hole with your thumb so coolant doesn't leak everywhere.......... or drain the system again.
 

·
Registered
Joined
·
370 Posts
Discussion Starter · #7 ·
Since you've already refilled your coolant system, the plumbers tape would be your best bet. Have an assistant ready to apply the tape on the coolant temp sensor threads while you plug the hole with your thumb so coolant doesn't leak everywhere.......... or drain the system again.
Ok ill do that thanks man
 
1 - 7 of 7 Posts
Top