Chevy Impala SS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
293 Posts
Discussion Starter #1 (Edited)
Looking for a good part number or replacement for the gauge sensor, in the right cylinder head, and connector if possible. Tore mine up doing header swap.

Thanks

Mike
 

·
Registered
Joined
·
7,988 Posts
This Sticky has all the part numbers you would probably need. I think it was on the 2nd page that had the Gauge Sensor...

http://www.impalassforum.com/vBulletin/showthread.php?t=227215

Those are GM numbers that you could cross reference if you want to go aftermarket. Most sites, like Autozone or Advance you can go to and enter all the info and find the part number they offer for the sensor. I've used duralast brand sensors for years without issue....usually in stock and cheaper than GM.
 

·
Registered
Joined
·
293 Posts
Discussion Starter #3 (Edited)
This Sticky has all the part numbers you would probably need. I think it was on the 2nd page that had the Gauge Sensor...

http://www.impalassforum.com/vBulletin/showthread.php?t=227215

Those are GM numbers that you could cross reference if you want to go aftermarket. Most sites, like Autozone or Advance you can go to and enter all the info and find the part number they offer for the sensor. I've used duralast brand sensors for years without issue....usually in stock and cheaper than GM.

Now riddle me this: I have the Z-28 dash swap (I did not do it). Will the sender in the head be different, will I need a F-Body sender??

And Thanks for the info!!

Mike
 

·
Registered
Joined
·
7,988 Posts
Now riddle me this: I have the Z-28 dash swap (I did not do it). Will the sender in the head be different, will I need a F-Body sender??

And Thanks for the info!!

Mike
Right there with you as I also have the Z Cluster in my 95. When I did the swap, I did NOT replace the Sensor for the gauge and it seems to work within range. Now if we're talking Oil Pressure sensor, that's a whole nuther discussion. :)

Can't remember if the install instructions for the Cluster touched on this or not, but the Caprice Coolant Sensor works fine in my setup. You could just for the heck of it look up the part number for both and LT1 in a Camaro and Caprice/Impala to see if they are different. I suspect they are both the same, but if different, I would not worry about it.
 

·
Registered
Joined
·
293 Posts
Discussion Starter #5
Right there with you as I also have the Z Cluster in my 95. When I did the swap, I did NOT replace the Sensor for the gauge and it seems to work within range. Now if we're talking Oil Pressure sensor, that's a whole nuther discussion. :)

Can't remember if the install instructions for the Cluster touched on this or not, but the Caprice Coolant Sensor works fine in my setup. You could just for the heck of it look up the part number for both and LT1 in a Camaro and Caprice/Impala to see if they are different. I suspect they are both the same, but if different, I would not worry about it.
Ok sounds good I might hit the dealer up today see what I can find, and we chatted a few years ago at Carlisle.

Thanks

Mike
 

·
Registered
Joined
·
293 Posts
Discussion Starter #7
I just replaced mine in my 96 Impala from Napa and it is part number TS4019.
Thanks for everyone's help and input, I went to the dealer and got the sender and connector, worked like a champ, and even got a discount.

Mike
 
1 - 7 of 7 Posts
Top