Chevy Impala SS Forum banner
1 - 18 of 18 Posts
G

·
Discussion Starter · #1 ·
I'm just wondering if anyone else has alot of squeaking after their rebuild of the front end.

I really like the new parts on the front but it seems to squeak quite a bit still and I was wondering if this is normal and after a while will go away.

Mostly the squeaking is heard while driving down the road or over rough ground, very noticable and embarrasing to me.

Coming to a stop the front squeaks like crazy until I stop.

I've had it lubed a few times but doesnt really seem to help. While parked I can get out and push up and down on the front drivers side bumper, the squeak can be heard some. Not exactly sure but with the hood open it could possibly be a control arm bushing.
 
G

·
Discussion Starter · #2 ·
Phil,

Did you install the kit yourself? If so, did you follow this procedure? If you had it installed by a shop, sometimes they skip this step regardless of what you request.
 
G

·
Discussion Starter · #3 ·
No I didnt install the kit myself. I had a local shop do the work. Don't know if they followed that procedure or not. So the procedure says to dismantle the bushings and lube them up before install?
 
G

·
Discussion Starter · #4 ·
Yes. The bushings came with a tube of white grease, which I'd assume the shop did not use. I'd bring it back to them and tell them it's squeaking and ask how they lubed it.

The bushings will not squeak if properly lubed.
 
G

·
Discussion Starter · #6 ·
So FaSSt

How long does the grease hold up over time, will they ever begin to squeek later on?

I'm wanting to use the PST bushings in the frame rebuild I'm doing now, just waiting until I have enough money saved.
I may have to just get the bushings only and not the kit with any of the steering linkage.

How much for PST Polygraphite:
All 8 front control arm bushings
Both upper inner shafts
All 8 rear control arm bushings
 
G

·
Discussion Starter · #7 ·
I removed the bushings, lubed them up and sent them to get pressed in. Aside from pressing in the bushings, I installed the front end. I did this in April and to date, it doesn't squeek.
 
G

·
Discussion Starter · #8 ·
Got bearings, what grease did you use cause the white grease that came with my kit was used and it squeaks like Phils?
 
G

·
Discussion Starter · #9 ·
I'm using the grease that came with the PST kit. I coated EVERYTHING... the bushings, shells and the sleeves. I also put some on the sides of the bushings where it contacts the frame (lower arms). Any place where there is metal to bushing contact, I lubed it.
 
G

·
Discussion Starter · #10 ·
I too have the PST kit, and no squeaks. I lubed the hell out of everything, but did have a shop do the bushings. I made sure to repeatedly say "grease the bushings." It handles great and no noises yet.
 
G

·
Discussion Starter · #12 ·
Also lubed the hell out of mine. Not a sound out of the suspension since day one. I have about 5-7K on the car now since the install.

B. Currey
 
G

·
Discussion Starter · #13 ·
The other night I went out to the garage and pushed up and down on the drivers side...squeaked pretty good. I opened the hood and listened to try and figure out where it was coming from. Seemed to come from low down near the rear of the A-arms so I took some WD40 and sprayed the bushing at the bottom arm towards the rear. Pushed up and down and it was squeaking some. Next day we drove around and I didnt notice any squeaks anymore.

Hard to imagine all those squeaks were coming from that one little spot.
 
G

·
Discussion Starter · #15 ·
I lubed the hell out of mine too... But I DID NOT PULL THEM APART. There was a tag in the box noting that they were greased before assembly. I pulled one half way apart, and sure enough they were greased already. My kit only came with one tube of the sticky grease, so when that was gone I used a can of spray lithium grease, and coated the heck out of everything.

No squeaks to date...
 
G

·
Discussion Starter · #16 ·
Well to date I've still got some squeaking but I've pretty much ruled out the upgrade kit. I believe it really is coming from an upper body bushing in the 1-3 positions on the drivers side. Possibly one and two and maybe three to an extent.

I may be looking at getting a full set of those polygraphite body bushings from you Zack ;)
 
G

·
Discussion Starter · #18 ·
Arnie,

We used to sell the body mount bushings from PST. We no longer carry their products due to our new line of PolyPerfect bushings. We will be offering those eventually, but I don't have a time frame as of yet.
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top