Chevy Impala SS Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
547 Posts
Discussion Starter · #1 ·
I'm accelerating hard coming on the parkway and if I have to slow down quick I hit the brakes and they are freakin hard! Then, after a few seconds they start to work and move down.
What the hell is that?
 

· Registered
Joined
·
1,782 Posts
I'm accelerating hard coming on the parkway and if I have to slow down quick I hit the brakes and they are freakin hard! Then, after a few seconds they start to work and move down.
What the hell is that?
sounds like initial symptoms of booster failure or somethng wacky w/ the vacuum. when you say "they are freakin hard", does it stop at all or do you have to wait until they "work and move down" before you can feel the brakes working again?

let us know how old the brakes are and what's been done to them recently/at all.
 

· Registered
Joined
·
560 Posts
After you shut the car off do you get one good vacuum assisted push of the pedal or is it hard as a rock right away? No need to be driving for this just go outside and step on the pedal.
 

· Registered
Joined
·
746 Posts
Bad check valve at the booster
 

· Registered
Joined
·
547 Posts
Discussion Starter · #6 · (Edited)
WOW!!! thanks for the replys...
SEO9C1, It's like a rock at first, then it slowly moves down and back to normal. One time I was getting close(25feet) to another car and THANK GOD they didn't hit the brakes like most jerkoffs on the road...whew

96CapriceMGR, I'll check it before I go back to work and post results later tonite...

Keith, I can see me gunning it and crashin like a NHRA Funnycar...lol
Honestly man, I don't think I'll see the track this year. Funds from kitchen remodel and not getting what I need from tranny. Higher stall and rebuild would work...

McGinnis, I'll definitely keep that in mind, got a vacation coming up at end of month to change it out if so, and my seals are done on my steering box.
 

· Registered
Joined
·
547 Posts
Discussion Starter · #7 ·
Well Manager, I tried the pump with car off and it felt okay...Could this just be air in the system? Oh wait a minute, I fixed and bled the other Caprice. This one had no brake issues to date. I guess it might just be the brake booster. I got a spare in my garage, I just hate squeezing my large frame under there...
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top