Chevy Impala SS Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
615 Posts
I did this mod to my wagon, but I used wiper arms from a 2000 Monte, that a friend was scrapping. I love the mod, but I cant get the washers to squirt properly. I may install squirters on the hood from some other car to get the system to work.
These wipers work just fine. They do a great job wiping, I just havent got the squiters squirtin' right yet!
Finally got the squirters working right. The tee sending fluid to the pass. side arm was snapped. Replaced with a good one from my collection, and now squirts GREAT!!
So this means w-body wipers can be added to the list correct? I can find '00 impalas easier around my way.
 

· Registered
Joined
·
615 Posts
So this means w-body wipers can be added to the list correct? I can find '00 impalas easier around my way.
I was at the yard today and was about to grab some '04 impala wiper arms, they would not fold up as far or stay up as Navy's pics show (actually they dont even look like the ones in his pics either). So Im back to searching for non w-body cars.
 

· Registered
Joined
·
615 Posts
I installed the new arms with the Bosch Icon blades (unfortunately, I got a 21" for the passenger side by mistake, but that isn't the problem).

For the record, LH is driver side and RH is passenger side, correct? I can be a** backwards, sometimes.

I put the angled arm on the DS, but switched it to the passenger side. The hood kept hitting it. There seemed to be a lot of clearance between the windshield and the angled arm when it was on the DS; the only way I could get it so the hood would clear was to set it higher up on the windshield and that's too high - it looks like it's on the intermittent setting.

After the switch, there were no problems with clearance for the hood. However, the arm sweep went well off the windshield on the drivers side. I know I got the correct part numbers. I put a 22" blade on the drivers side and a 21" on the passenger side. As I said in the beginning, I got the 21" by mistake, but that shouldn't affect the sweep or height problems I'm having on the drivers side.

Any thoughts? Or in a word, HELP!
The bent arm needs to be on the LH (drivers) side. That sounds like why your arm is going off the windshield. The bent arm will sit higher off the windshield than the factory arm. Sounds like you might not have had the arm tightened down good enough (my assumption). I will go out and take a pic of mine.



 

· Registered
Joined
·
615 Posts
The drivers side arm may be VERY CAREFULLY bent to allow it to park nearer the bottom and to enhance appearance and correct uneveness. Do it with the wiper blade removed. I used 2 small blocks of wood for protection with a vise grips. Bend a very little at a time and hold the arm so it does not twist on the shaft wrecking the shaft knurling and distorting the arm geometry.

BTW - 20" on the passenger side is best.

Also - still looking for a similar setup for the wagon rear - see my previous thread in wagon section.
I was thinking that also, I will try bending it at work tomorrow.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top