Chevy Impala SS Forum banner
121 - 135 of 135 Posts

·
Registered
Joined
·
3,094 Posts
I thought it was Bonneville and LeSabre 01-05. (without checking every previous post here - it's in here somewhere).

With those arms, 20" and 24" work properly. If they don't, arms need to be reset on the shaft.
 

·
Registered
Joined
·
7,884 Posts
Though my Impala does not have wipers. I typically use semi-gloss engine enamel for parts like this.
 

·
Registered
Joined
·
934 Posts
If you have a lkq in your area its cool cause u can search there inventory of cars and wiper arms are only 6. I found a couple at mine
 

·
Registered
Joined
·
1,176 Posts
I ordered the part numbers on the front page from GM parts direct with the Bosch Icon Blades 22/20, and the wiper goes past the pillar. think i may have to go 20/20

it makes one wipe ok, the second wipe after its dry grips at the edge, the other wiper goes down, and when it comes back up drivers side one goes over the pillar. then its stuck till i park and reset them
 

·
Registered
Joined
·
292 Posts
Just did this a couple of weeks ago and used the Bosch Icon's. Definitely an improvement over the originals! For the last 9 years I've used mostly Rain X Latitudes as they didn't chatter with the original arms and seemed to last a long time (1 year) but the last couple of years the quality seems to have gone down hill and even new sometimes they streak. I've tried the Bosch Icon's on a couple of my other cars with good luck over the last 1.5 years (haven't had to replace any yet) and hope these work as well. The washers seem to be much better than what I had working before as well, mine had either broken or clogged to the extent they didn't wash real well. Like a new car!
 

·
Registered
Joined
·
1,732 Posts
IDK what wiper arms y'all are using that you're having problems/needing shorter blades.

I bought LeSabre wiper arms here and used the 22A, 21B Bosch Icons recommended in this thread and have absolutely no issues.


You guys are either using the wrong arms or you have them on the wrong side or something. It's not like your cars are shaped differently lol! I didn't even have to adjust after installing them. Perfect on the first try. cwm2
 
121 - 135 of 135 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top