Chevy Impala SS Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
188 Posts
Discussion Starter · #1 ·
I was driving today about 40 mph when my 94 9c1 with 152k died. The dash and the stereo stayed on but the engine wasnt running. I tried starting it a couple of times and got nothing. The starter was cranking but it wouldnt fire up. I checked under the hood and found nothing out of the ordinary besides the positive battery connection was a little loose. I tightened it and waited a few minutes and when I tried to start it again it ran. I drove it about 8 miles on the highway and 1 mile through the city and parked it in my parking garage. Next time I go to the car 5 hours later it starts but wont stay running for longer than 3 or 4 seconds. Nothing happens when I press the gas. It will turn over, halfway start then make a sucking sound through the intake until it dies. I just replaced the fuel pump about a thousand miles ago and when I pressed the schrater valve in the fuel line fuel shot out. So its not starving for fuel right? This is where I am at right now please let me know what you guys think I should do now
 

·
Registered
Joined
·
3,096 Posts
In those 152K, when was the cap and rotor last changed?
 

·
Registered
Joined
·
3,505 Posts
Follow the diagnostic tests above. Check the coil and ICM. The symptoms would lead one to think that those are more likely the problem than the opti.
 

·
Registered
Joined
·
895 Posts
I had same problem after I changed cap and rotor
it starts fine as soon as it warmed up it died

find out my primary fan was shut ,changed the fan motor and is good now

of course that is one possibility,after you checked for fuel pressure

apparently if PCM don't see power from primary fan coming back to it ,consider the car is over heating even if the secondary fan comes on and it shuts of the coil,
 

·
Registered
Joined
·
3,612 Posts
Check fuel pressure FIRST! Pressing down on the Scharader valve doesn't tell you anything. You could have a small amount of pressure, so you see fuel, but it's nowhere near enough to allow the car to run properly. 41 - 47 psi key on, engine off.
 

·
Registered
Joined
·
546 Posts
I had same problem after I changed cap and rotor
it starts fine as soon as it warmed up it died

find out my primary fan was shut ,changed the fan motor and is good now

of course that is one possibility,after you checked for fuel pressure

apparently if PCM don't see power from primary fan coming back to it ,consider the car is over heating even if the secondary fan comes on and it shuts of the coil,
Did I read that right? Have I learned something new already today?
 

·
Premium Member
Joined
·
8,383 Posts
I don't know how true that statement is, I don't think that the PCM cares if the fans are running or not, maybe if it senses that the car is overheating via the ECT then maybe but there is no feedback to the PCM from the fans.

OP- definitely check fuel pressure first. On my car I found the ICM to be bad as well and I am still dinking with the fuel pressure thing in my car. Good luck.
 
1 - 8 of 8 Posts
Top