Chevy Impala SS Forum banner

1 - 6 of 6 Posts
L

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I got the bar for free from one of my Buddy's it came of 79 T/A WS6 and powdered coated it in glossy black, so i did my home work and searched and searched what i found out after the search that this bar is best if used with HA or HO rear bar so my question is it gonna be safe to run it with out the HA or the HO rear bar? My other question is which bushing and end links do i need to use does any one have a part number for those parts? Thanks for all the help.
 
A

·
Guest
Joined
·
0 Posts
Discussion Starter #2
It'll work fine with the stock rear bar....in fact, given your car setup (power, tranny and posi-wise) you'd probably find the HA or HO rear bar is too big.

You need the 1.25" GREASABLE Energy Suspension swaybar bushings, as well as new bolts (from GM) for those bushings. I'd also replace the endlinks while you're in there.
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Thanks for the reply Ed, one more question, the bolts and the end links do they have to be for the WS6 or the impala one's will work? Thanks allot.
 
A

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Bolts : Impala ones

Endlinks : take off the ones you have now, and goto the parts store (AZ in Huntsville should have them). Match up and get the closest length ones you can to what you have now. When you reinstall, do so with the weight of the car ON the suspension and torque them down to 15 ft-lbs.
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #5
Hey man. Its perfectly fine to run the WS6 swaybar in front with stock swaybar in the rear. That's what i'm running right now and its fine. I'm using 1LE endlinks and you do need to buy the 4 new bolts to install the bar.

check out the tech articles at theherd.com
helped me out a lot. Good luck
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #6
Originally posted by SSlumpin Imp:
Hey man. Its perfectly fine to run the WS6 swaybar in front with stock swaybar in the rear. That's what i'm running right now and its fine. I'm using 1LE endlinks and you do need to buy the 4 new bolts to install the bar.

check out the tech articles at theherd.com
helped me out a lot. Good luck
Yes that really help thanks allot.
 
1 - 6 of 6 Posts
Top