Chevy Impala SS Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
384 Posts
Discussion Starter · #1 ·
Evidently my post was the one that broke the servers back, since it was as i hit POST that the site went down and it seemed to have taken HALF my post (just the title)

Somehow my cruise control Clip, the one that attaches to the bracket on the throttle body, came up missing... the odd thing here is that I have had my wagon back for 6 months, and I have removed this a few times, and I have had cruise control within the past few months... and now it is gone.

Someone else looked at it, and said that i must have replaced my cruise control cable... I dont think this happened unless one of my neighbors swapped it out while my car was down.


Also looking for an ABS computer. or at least the shop that tested it said it was the only thing left that could be the issue. OBD1 abs.. i have a 95 caprice.

will take a photo of the Cruise COntrol Clip in a little bit.
 

· Registered
Joined
·
938 Posts
Abs

Hey I couldnt get the search to work on forum for my link so I will repost picture. Here is the pic for you. $75 to door in Houston OBO. Im 90% It was from a 95 sheriffs car that I parted out back in Feb (may have been a 96). The GM part number is 10263085. Thanks let me know if your interested.
 

Attachments

· Registered
Joined
·
938 Posts
Oh and yes and in working condition-Steve
 

· Registered
Joined
·
414 Posts
I got mines off my 94 impala ss. Both ABS and Cruise control with cable
 

· Registered
Joined
·
938 Posts
Ok thats cool man LMK....
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top