Skip White Optispark .... Lt1 Ignition - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 11-10-2014, 09:24 AM Thread Starter
Senior Member
 
supersporty's Avatar
 
Join Date: Aug 2014
Posts: 157
 
Skip White Optispark .... Lt1 Ignition

I have heard that skipwhiteperformance.com offers opti sparks and caps for the lt1.

Does anyone have any experience in the parts they sell?
They offer a brand new opti and the cap for about 60$.

Please let me know if anyone has purchased one if these units and how it has performed...
supersporty is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 11-13-2014, 11:57 AM
Senior Member
 
Join Date: Jan 2003
Location: 54911
Posts: 780
 
I installed one in the wife's 95 B4U a couple of months back and it's been running fine. It's a little early to say how it'll hold up, but so far so good.

-Jim

1968 Camaro -my first car.
1995 Purple Pearl B4U Caprice
1995 Black/White 9C1 Caprice--NADACOP
1995 Purple Pearl L99 Caprice
2012 Alto Gray Metallic 9C1 Caprice--The HoDag-Solo axle back exhaust, improved racing OTR CAI intake.
NADACOP is offline  
post #3 of 9 (permalink) Old 11-13-2014, 04:11 PM
Senior Member
 
Join Date: Feb 2002
Location: nj
Posts: 1,161
 
Send a message via AIM to bigblock671
i use them all the time had one in my old tow car for 2 years now

350 musi alum heads 503 cam 11.93 1.62 [email protected] n/a 11.50 @115 1.52 60 100 shot
bigblock671 is offline  
 
post #4 of 9 (permalink) Old 11-13-2014, 04:41 PM
Senior Member
 
Rocko350's Avatar
 
Join Date: Apr 2007
Location: Mount Airy,MD
Posts: 3,913
 
I have one in each of my 3 cars and a spare in the shop just in case. The bearing on my last one went out. Only reason i pulled it. Had oil inside. There used to be a high quality timken bearing number you could renew it with that made the opti like new again, but I cant find the info anywhere though.

Chris

94-95 Scan. Free, well written diagnostic software
http://www.mediafire.com/?0elo4c935uc5s
Rocko350 is offline  
post #5 of 9 (permalink) Old 11-14-2014, 07:21 AM Thread Starter
Senior Member
 
supersporty's Avatar
 
Join Date: Aug 2014
Posts: 157
 
Thank you all for your input.

Have any of you noticed any power loss or any diffrence in performance, between delco and the skip white ?

I'm leaning towards buying one now that there's been 3 positive responses, and no one has chimed in to say that theyre garbage ....
supersporty is offline  
post #6 of 9 (permalink) Old 11-14-2014, 10:44 AM
Senior Member
 
Bugman's Avatar
 
Join Date: Nov 2004
Location: Evansville, WI
Posts: 3,642
 
I'm in the same boat and looking at getting a Skip White to have as a backup. A general search across several forums turn up a lot of "you get what you pay for" type posts, but there are very few actual failure reports.

Disclaimer: Any hokey-assness on my personal vehicles does not reflect the quality of my work done while I'm on the clock
Bugman is offline  
post #7 of 9 (permalink) Old 11-14-2014, 01:12 PM Thread Starter
Senior Member
 
supersporty's Avatar
 
Join Date: Aug 2014
Posts: 157
 
When I spoke to the people at skip white, they said that they sell 1 or 2 of these optis per month and he said that in the past 4 years he could only recall one coming back from a dissatisfied customer.

So, I am probably going to try one and hope it does what its supposed to....
supersporty is offline  
post #8 of 9 (permalink) Old 11-15-2014, 08:28 PM
Senior Member
 
Scuba Steve's Avatar
 
Join Date: Jun 2006
Location: Livonia, MI
Posts: 883
 
Garage
I threw one in my SS a couple weeks ago. Trans went out about 400 miles later so I haven't run it very long but it sems fine so far.


1996 Impala - 190,000 miles - 1/4 mile: 14.94
2008 Grand Marquis - 1/4 mile: 16.26
Scuba Steve is offline  
post #9 of 9 (permalink) Old 12-15-2014, 07:32 PM
Member
 
Lord Vader's Avatar
 
Join Date: Jul 2011
Posts: 99
 
optispark

So I got and installed one of these Skip White Optisparks. The car runs great, but I have no vacuum at the snorkel. I checked the vacuum harness, and it all works fine, no leaks, filter and check valve installed correctly. I have vacuum to the distributor, but nothing on the other side going to the snorkel. Those of you that have these, do you have vacuum at the snorkel as described in the Buick Know How video? https://www.youtube.com/watch?v=lFCjaz6zHfc
Lord Vader is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome