So My caprice is back on the road as of 3 weeks ago. - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-17-2016, 06:18 AM Thread Starter
Junior Member
 
Join Date: Dec 2015
Posts: 11
 
So My caprice is back on the road as of 3 weeks ago.

The deer hit took out the electric fan too and there's no shroud in yet. Good thing my dad told the insurance company he couldn't open the hood due to the airbags. They would of totaled if they seen the fan damage and all. The airbags still work as the light comes on and blinks like it's working.Alsoo gotta get my original hood emblem on it. It survived. Still on the the old hood. I only have one fan and it still runs cool.

But I have a weird issue. The alarm light was always red and it was like that even after it was fixed. We got a cold spell and since then the light flashes and if i have the door opened and hit the lock button an alarm comes on and it won't go off until I press the wireless remote to lock it. and as of Wensday when i get in it and lock the doors and try to start it the alarm comes on and it won't go off untill i press the remote button. I can't start it until I it goes off. The dash lights up. It also makes a noise when i use the keyless button. The thing is it sounds like a newer alarm when it flashes when i open the door for a second with the keyless entery. I noticed it has an alarm sticker on back. The guy that owned the car kept the theft lock off on the radio but he also kept the manual.
Joeyss is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome