93 Lo5 Caprice throwing code 45 - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 01-04-2019, 08:33 PM Thread Starter
Senior Member
 
<<1 of 1>>'s Avatar
 
Join Date: Jun 2009
Posts: 306
 
My 93 caprice is running pretty rough right now. Throwing code 45. Running rich. Well my temp gauge isn't working. Haven't figured that out yet. But I noticed that the steel tube running from the smog pump is broken. By any chance would that make the car stumble and die.

<<1 of 1>> is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 01-05-2019, 12:42 PM
Senior Member
 
babywag's Avatar
 
Join Date: Mar 2016
Location: California
Posts: 975
 
No, not your problem.

Most common problem for pig rich is failed ECT or wiring.
With a bad sensor the engine will run absolutely horrid because the temp reported it WAY below actual temp.
babywag is offline  
post #3 of 10 (permalink) Old 01-05-2019, 01:47 PM Thread Starter
Senior Member
 
<<1 of 1>>'s Avatar
 
Join Date: Jun 2009
Posts: 306
 
I've changed temp sensors both of them. One on driver's side head between 1 and 3 cylinder and the one on the intake. Changed pigtails and grounds. Temp gauge won't work still. Changed EGR valve today fixed the steel tube coming from the smog pump. Now it's running good. Temp gauge still not working though

<<1 of 1>> is offline  
 
post #4 of 10 (permalink) Old 01-05-2019, 08:49 PM
Senior Member
 
Fred Kiehl's Avatar
 
Join Date: Feb 2009
Location: Largo, FL 33774
Posts: 10,838
 
I had this exact problem with my 92 OCC. Try reseating the ground at the upper coolant hose adapter. The bolt can get corroded, and then the ground fails. It is the ground for the computer and the O2 sensor. Make sure the engine is cold, so the coolant does not leak around the adapter. Clean the threads in the manifold, and the threads on the bolt. I also would put some dielectric grease on the threads before reassembly. A small wire brush, like a gun barrel brush, will work on the manifold, and the bolt can be cleaned on a bench grinder with a wire wheel on it. This immediately fixed the problem.

1991 OCC 461 (.030 over 454) BBC, 3.23 posi, flash to pass, drop spindles & springs, Impala rims, Hydroboost, Recaros, MOMO/wood SW w/QR, custom wood shift knob, Pioneer DEH P77DH
1992 OCC now with 5.7 tbi, DEH P77DH
For a parts list, check https://www.impalassforum.com/vBulle...ion-parts.html
Fred Kiehl is online now  
post #5 of 10 (permalink) Old 01-05-2019, 08:55 PM
Senior Member
 
Fred Kiehl's Avatar
 
Join Date: Feb 2009
Location: Largo, FL 33774
Posts: 10,838
 
In doing the other repairs, you may have bumped the ground.

The sensor that controls the gauge is the one on the driver's side head. Make sure you got the correct type, the one on the manifold is different from the one on the head. The one on the head has a thicker extension going into the water jacket.

1991 OCC 461 (.030 over 454) BBC, 3.23 posi, flash to pass, drop spindles & springs, Impala rims, Hydroboost, Recaros, MOMO/wood SW w/QR, custom wood shift knob, Pioneer DEH P77DH
1992 OCC now with 5.7 tbi, DEH P77DH
For a parts list, check https://www.impalassforum.com/vBulle...ion-parts.html
Fred Kiehl is online now  
post #6 of 10 (permalink) Old 01-05-2019, 09:41 PM Thread Starter
Senior Member
 
<<1 of 1>>'s Avatar
 
Join Date: Jun 2009
Posts: 306
 
It's the right sensor. I noticed that the original one had 2 prongs where the connector plugs to buy the new one only has one. Checked everywhere even online guess that's how they're made now. And the grounds I changed eyelets right at the thermostat housing, are those the grounds you're talking about. Car was running just fine earlier now it's stumbling bad. No idea what to do anymore. Not throwing any codes no nothing. Acting like it's not getting fuel but pump is good filter is new. New tps EGR valve map sensor.

<<1 of 1>> is offline  
post #7 of 10 (permalink) Old 01-06-2019, 02:25 AM
Senior Member
 
Fred Kiehl's Avatar
 
Join Date: Feb 2009
Location: Largo, FL 33774
Posts: 10,838
 
What brand of pump do you have?

You must remove the bolt and clean the manifold threads, and the bolt threads. it is a PITA to check the fuel pressure on a TBI car. Check your PCV valve.

I picked an engine fuel line from a 91 or 92 Fleetwood, it has a Schrader valve on the line.

1991 OCC 461 (.030 over 454) BBC, 3.23 posi, flash to pass, drop spindles & springs, Impala rims, Hydroboost, Recaros, MOMO/wood SW w/QR, custom wood shift knob, Pioneer DEH P77DH
1992 OCC now with 5.7 tbi, DEH P77DH
For a parts list, check https://www.impalassforum.com/vBulle...ion-parts.html
Fred Kiehl is online now  
post #8 of 10 (permalink) Old 09-13-2019, 12:04 PM
Senior Member
 
Join Date: Oct 2008
Location: Indy
Posts: 146
 
Did you get the correct EGR valve-there’s 3 different ones? I go thru this ordeal with O’Reilly and I have them order the one in my file which was cross referenced. The part in their computer is completely wrong and gives wrong operation to vacuum reference.
What about EGR solenoid operation condition?
I added in a schrader valve my tbi on my 93-helps eliminate fueling issues- best $20 spent

hit it with a hammer
IndyL03 is offline  
post #9 of 10 (permalink) Old 09-14-2019, 07:40 AM
Senior Member
 
Fred Kiehl's Avatar
 
Join Date: Feb 2009
Location: Largo, FL 33774
Posts: 10,838
 
You did a number of things, and any one of them could be the culprit. It is too bad that you probably already threw the old parts out. You could replace them one by one until the issue goes away.

You should revisit the temp sensor. If the original one has two wires, that could be the issue. It does not matter if the part was sold to you as the correct part, mistakes have occurred, and the part may not be the correct one.

1991 OCC 461 (.030 over 454) BBC, 3.23 posi, flash to pass, drop spindles & springs, Impala rims, Hydroboost, Recaros, MOMO/wood SW w/QR, custom wood shift knob, Pioneer DEH P77DH
1992 OCC now with 5.7 tbi, DEH P77DH
For a parts list, check https://www.impalassforum.com/vBulle...ion-parts.html
Fred Kiehl is online now  
post #10 of 10 (permalink) Old 09-14-2019, 10:14 AM
Senior Member
 
gbhs72's Avatar
 
Join Date: Nov 2015
Location: Lawton, Ok
Posts: 1,442
 
This? https://www.rockauto.com/en/moreinfo...37427&jsn=1792

Mark: Snowman-33

93 9C1: Work & Cubic Ca$h This started with a new headlight and fender Celeritas In Conficiendo
gbhs72 is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome