dead battery and buzzing - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-13-2013, 07:55 AM Thread Starter
Senior Member
 
Caprice Luva's Avatar
 
Join Date: Jan 2008
Location: Washington D.C.
Posts: 187
 
dead battery and buzzing

About a week ago I got out my car and noticed a buzzing sound coming from under it. It sounds like its in the back. It has done the same every day since. I went to start it yesterday and the battery was dead. Jumping it didn't work but all lights came on and it kept clicking like it want to start but wouldn't. The buzzing sound was going on the whole time. I checked to see if any gas was spraying into the tb and nothing. It also has a slight barely noticable shake at lights. One day last week when I stopped at a light it started shaking a lot for a few seconds til I hit the gas and it stopped. I'm guessing fuel pump any body else have any ideas what it might be

Born in DC
Caprice Luva is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-14-2013, 09:32 PM Thread Starter
Senior Member
 
Caprice Luva's Avatar
 
Join Date: Jan 2008
Location: Washington D.C.
Posts: 187
 
None of you rat bastards replied to my post but that's ok. Just for other people who come across this problem I'll tell what I found. The noise is the self leveler at the back of the car. Its defective comes on and off when it wants and killed the battery

Born in DC
Caprice Luva is offline  
post #3 of 3 (permalink) Old 10-14-2013, 11:08 PM
Senior Member
 
Mr pogo's Avatar
 
Join Date: Oct 2003
Location: SoCal
Posts: 6,358
 
lol, you posted in the wrong forum that gets little traffic.

evil T-47 seatbelt bolts and cutdown ZQ8 bumpstops, Kore3 front brakes, TB bypass, Dynotech DS, F-body EGR, Meziere WP, Comp Cams 1.6RR/CM springs, trans by Moi Industries, Yank 3600, Earls trans cooler/rad cooler delete/Derale t-stat, RAISS, SLP headers, SLP injectors, pypes X-pipe/magnaflows, Borgeson shaft, Hotchkis springs, PPM front stuff, Metco rear arms, Clear Image DS loop/trans crossmember, 3.73s, eaton posi, Hypertech for smog \"[<img BH tuned PCM
Mr pogo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome