9c1 cluster swap into civi caprice using roadmaster connectors. - Chevy Impala SS Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 04-27-2014, 05:10 PM Thread Starter
Junior Member
 
Join Date: Apr 2014
Posts: 24
 
9c1 cluster swap into civi caprice using roadmaster connectors.

I've searched around to find information to switch my 93 'granny' cluster out for my old 92 9c1 cluster.

My problems arose when I found out I didn't have the original connectors from my 92 9c1 wiring.

So I went to the local pullapart and found a 92 roadmaster and got the pigtales for it.

I followed a guide to put a roadmaster cluster into a caprice as the wiring is different.

Plugged in the 9c1 cluster, nothing worked as expected due to the pin locations.

I followed the guide to install a 9c1 cluster I to a roadmaster since that's what the guide I followed was.

I switched the pins from road master to caprice and reinstalled the cluster.

Now I have

no digital Speedo (i remember reading that I may have to tie into headlight to dim it but I don't get any display.)

No tachometer (i have not run the wires to ecu or the coil)

Idiot amp light works but the amp gauge does not.

Coolant gauge works

Fuel gauge works

Idiot oil pressure light works but the gauge does not.

No Check engine light

High beam and turn signals work.

Most importantly the odo and the tripometer are not working.

I'm trying to find a 9c1 set of connectors and just 're wire into those. But they are hard to come by here in Cleveland Ohio.

The help I need is a fsm page on the 1993 caprice connectors and 1992 road master connectors . So I can make sure I did the repinning properly. I really don't want to put the granny cluster back in.

Sent from AutoGuide.com Free App

1993 Tan Civi Classic L03 195,xxx
(9c1 Wheels/Tires , 9C1 cluster swap, more to come)

1992 White 9C1 L05 245,xxx
(Blown Motor / Parts / Junked)

Last edited by mikon; 04-30-2014 at 11:40 PM.
mikon is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 04-27-2014, 05:58 PM
Senior Member
 
Fred Kiehl's Avatar
 
Join Date: Feb 2009
Location: Largo, FL 33774
Posts: 10,838
 
If you get a 91-93 FSM, it should have the two different pinouts for the 9C1 and the civi in it.

1991 OCC 461 (.030 over 454) BBC, 3.23 posi, flash to pass, drop spindles & springs, Impala rims, Hydroboost, Recaros, MOMO/wood SW w/QR, custom wood shift knob, Pioneer DEH P77DH
1992 OCC now with 5.7 tbi, DEH P77DH
For a parts list, check https://www.impalassforum.com/vBulle...ion-parts.html
Fred Kiehl is online now  
post #3 of 12 (permalink) Old 04-27-2014, 06:44 PM Thread Starter
Junior Member
 
Join Date: Apr 2014
Posts: 24
 
Quote:
Originally Posted by Fred Kiehl View Post
If you get a 91-93 FSM, it should have the two different pinouts for the 9C1 and the civi in it.
Thank you for your quick response.

I've found a lit of very old threads with broken pictures, and threads that had all info from the old forums that are now lost.

I know some users, have hosted pages, scans, etc from various manuals. Are you aware of any current sites or hosts that still have old pictures available.

I thank you again.

Sent from AutoGuide.com Free App

1993 Tan Civi Classic L03 195,xxx
(9c1 Wheels/Tires , 9C1 cluster swap, more to come)

1992 White 9C1 L05 245,xxx
(Blown Motor / Parts / Junked)
mikon is offline  
 
post #4 of 12 (permalink) Old 04-27-2014, 07:00 PM
Senior Member
 
Fred Kiehl's Avatar
 
Join Date: Feb 2009
Location: Largo, FL 33774
Posts: 10,838
 
I do not know anyone, but you can find the manuals on ebay.

1991 OCC 461 (.030 over 454) BBC, 3.23 posi, flash to pass, drop spindles & springs, Impala rims, Hydroboost, Recaros, MOMO/wood SW w/QR, custom wood shift knob, Pioneer DEH P77DH
1992 OCC now with 5.7 tbi, DEH P77DH
For a parts list, check https://www.impalassforum.com/vBulle...ion-parts.html
Fred Kiehl is online now  
post #5 of 12 (permalink) Old 04-27-2014, 07:21 PM Thread Starter
Junior Member
 
Join Date: Apr 2014
Posts: 24
 
Quote:
Originally Posted by Fred Kiehl View Post
I do not know anyone, but you can find the manuals on ebay.
Yeah, I've been looking at them a few nice ones pretty cheap. Again I thank you for your responses.


Edit...


I followed all of the traces from the connectors on the cluster and I have everything working with key on. Except for the tachometer ... I still need to run the wires.

I think the Speedo ground and the ground pins are switched, when I start the car the battery gauge and the Speedo stop working.

With key on and not started, the battery gauge shows the correct voltage, and the Speedo turns on and displays 0 mph.

Edit...

Today I figured out I had Speedo ground and ground swapped in the connector. Changed the 2 pins and the cluster is alive. All gauges work, all lights and indicators work.



Tachometer no go, I'm not sure where to connect the wire on the coil.

Odometer and trip meter also don't work. I assumed the speedometer would have fixed them as well but I was wrong.

Sent from AutoGuide.com Free App

1993 Tan Civi Classic L03 195,xxx
(9c1 Wheels/Tires , 9C1 cluster swap, more to come)

1992 White 9C1 L05 245,xxx
(Blown Motor / Parts / Junked)

Last edited by mikon; 04-30-2014 at 11:42 PM.
mikon is offline  
post #6 of 12 (permalink) Old 04-28-2014, 05:46 PM Thread Starter
Junior Member
 
Join Date: Apr 2014
Posts: 24
 
A few pics from the install, and pics used for the conversion.









I made my own pin chart based off of the layout of each trace on my 1992 9c1 cluster.








Before,



After,





I'm not sure if 91-93 civi has the resistor. I noticed this pic is of 94+ due to the trunk release located in the glove compartment




My inspiration for this small project was thanks to a thief who thought I shouldn't have a nice android radio in my caprice.




1993 Tan Civi Classic L03 195,xxx
(9c1 Wheels/Tires , 9C1 cluster swap, more to come)

1992 White 9C1 L05 245,xxx
(Blown Motor / Parts / Junked)

Last edited by mikon; 04-29-2014 at 10:32 PM.
mikon is offline  
post #7 of 12 (permalink) Old 04-30-2014, 06:18 PM Thread Starter
Junior Member
 
Join Date: Apr 2014
Posts: 24
 
Dom the view of the picture the pin at the top right, is for the tachometer, to me the traces seems to be pretty badly worn.

I'm tempted to hardwire the tachometer to test it out. If I take apart the cluster I'm assuming there will be 3 pins for the tachometer. + -, and white to connect to coil. Which terminal on the gauge is + the top, both - and the center gauge the tach wire ?

If the tach works and it's just the pin, I assume if I want to keep this cluster I'll have to solder in some wires to bypass the trace on the board.

Until I figure out the 9c1 tach and odometer, I'm going to install the road master cluster, to make sure all the wiring is correct and to test the tach wire I have hooked up



Sent from AutoGuide.com Free App
Attached Thumbnails
Click image for larger version

Name:	1398899506186.jpg
Views:	122
Size:	71.9 KB
ID:	80001  


1993 Tan Civi Classic L03 195,xxx
(9c1 Wheels/Tires , 9C1 cluster swap, more to come)

1992 White 9C1 L05 245,xxx
(Blown Motor / Parts / Junked)
mikon is offline  
post #8 of 12 (permalink) Old 04-30-2014, 06:52 PM
Senior Member
 
Fred Kiehl's Avatar
 
Join Date: Feb 2009
Location: Largo, FL 33774
Posts: 10,838
 
The tach goes to the white wire on the coil, and pin B1 on Connector 2. The ground for the tach is on pin A7 on connector 2 (black/white wire). The VSS signal goes to the B8 connector on Connector 1 (brown wire) and it also goes to the trip odometer internally.

1991 OCC 461 (.030 over 454) BBC, 3.23 posi, flash to pass, drop spindles & springs, Impala rims, Hydroboost, Recaros, MOMO/wood SW w/QR, custom wood shift knob, Pioneer DEH P77DH
1992 OCC now with 5.7 tbi, DEH P77DH
For a parts list, check https://www.impalassforum.com/vBulle...ion-parts.html
Fred Kiehl is online now  
post #9 of 12 (permalink) Old 04-30-2014, 09:02 PM Thread Starter
Junior Member
 
Join Date: Apr 2014
Posts: 24
 
Quote:
Originally Posted by Fred Kiehl View Post
The tach goes to the white wire on the coil, and pin B1 on Connector 2. The ground for the tach is on pin A7 on connector 2 (black/white wire). The VSS signal goes to the B8 connector on Connector 1 (brown wire) and it also goes to the trip odometer internally.
Thanks I was missing that last ground. I just jumped the pin 3 ground to pin 7 and everything is now 100% working. Tach and odo.

The problem I was having with the uncertainty with the coil was, ever picture showed a one problem connector. I have 2 connectors with a pink and white wire and none says tach. But I did have it on the right one. As soon as I connected the ground everything worked great. It's nice seeing the rpms again instead of just guessing what the engine is doing.

I hope this thread helps some of those out who are still interested in this type of swap.

Would you happen to know if this display is able to be tied into the parking lights to dim the Speedo, ? I'm fine with it but it's the only info I can't find.

Sent from AutoGuide.com Free App

1993 Tan Civi Classic L03 195,xxx
(9c1 Wheels/Tires , 9C1 cluster swap, more to come)

1992 White 9C1 L05 245,xxx
(Blown Motor / Parts / Junked)

Last edited by mikon; 04-30-2014 at 11:47 PM.
mikon is offline  
post #10 of 12 (permalink) Old 07-30-2014, 12:33 AM
Senior Member
 
Join Date: Aug 2004
Location: St Louis
Posts: 1,465
 
Thanks for posting Im about to give this a try to a buddy of mines 93 civ caprice
KDB50SS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome