Accelerator pedal seems hard to push. - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-11-2001, 02:41 AM
Chris 94Z A4
Guest
 
Posts: n/a
Post

Is there something I can do to help loosen the tension? I really have to try to push the pedal to the floor.

Thanks [img]redface.gif[/img]
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-14-2001, 12:19 AM
94LT1
Guest
 
Posts: n/a
Post

i would check if the cable is binding or gets caught on something somewhere.......i dont know what else would cause that

chris
post #3 of 3 (permalink) Old 12-14-2001, 12:34 AM
limp impg
Guest
 
Posts: n/a
Post

Check for cable fraying just before it into the firewall or where the cable exit up to linkage on throttle body Just worked on a dodge today that had a hard pedal.Last resort before buying a new cable. Try injecting it with oil. [img]0.gif[/img]
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome