Burrrrr - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-27-2006, 07:07 AM
no moa
Guest
 
Posts: n/a
Post

I have a 96 9C1 caprice, and i have for the last 2 years, not drivin it in the winter, because i have no HEAT, the heater core is new, its been flushed, forward and backwards. Still the engine will not warm up, i have bled the air out, got a new 160 thermostat.
Someone told me something about a vacumn line behind the pass side interior kick panel? I bought this car to drive in the winter, but not without heat....any help would be great.
No moa
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-27-2006, 07:18 PM
signguy
Guest
 
Posts: n/a
Post

Is 160 to low for the engine to get warm enough?
post #3 of 3 (permalink) Old 02-28-2006, 07:35 PM
SOB 9C1
Guest
 
Posts: n/a
Post

i had a 160 in my 96 and never had any probs. then the blower motor died in the middle of winter a few years back lol. but yeah my car never had a prob warmin up.... or comin close to overheatin in tourist traffic...
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome