How Hot are You? - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-01-2001, 08:03 PM
ssurf'n
Guest
 
Posts: n/a
Post

How hot does your Caprice run? I've got a 92 Wagon with a 350 TBI. It runs about a half a click past the middle. I'm running a 160 degree stat. Please post your response. Thanks,




Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-01-2001, 11:03 PM
FakeSS
Guest
 
Posts: n/a
Post

Hi Mike! As you know, I have a 93 Caprice with the 305 TBI. The temp gauge runs around the 1/4 mark. It only sees the 1/2 mark on heally hot days with the AC on in stop-and-go traffic. Then only while I'm standing still. When I start moving again it goes back down to 1/4.

Do you know if your radiator the factory original? If it is - and especially if it has ever had tap water put in it (you should always use distilled water) it may need to be rotted out.

If you do have the radiator rotted, be prepared - sometimes pin holes will appear that were previously plugged with sediment and, for lack of a better word, crud.

HTH

------------------
Jay - 93 DGGM Caprice "SS"



[This message has been edited by FakeSS (edited April 02, 2001).]
post #3 of 5 (permalink) Old 04-02-2001, 01:08 AM
UltraZone
Guest
 
Posts: n/a
Post

My 91 with the 305 runs normally at half way between the 1/4 and 1/2 mark. If I step on it hard it climbs to the 1/2 mark, but then it comes down fast to the original position. Also I don't have the original radiator.
 
post #4 of 5 (permalink) Old 04-02-2001, 04:58 PM
patgizz
Guest
 
Posts: n/a
Post

my 91 305TBI never goes over 1/4 even when towing. i put a 9C1 replacement radiator in it instead of the wimpy tiny stock one.
post #5 of 5 (permalink) Old 04-05-2001, 01:49 AM
LM13
Guest
 
Posts: n/a
Post

i don't have a caprice of my own yet, but i know for sure that dr's LT1 powered caprice usually runs at about temperature a bit over the middle, i can't recall any major probs caused by that, but i do remember that his car spit some antifreeze out a couple of times
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome