New 9c1 caprice owner with questions.. - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 11-15-2005, 07:55 PM
stl_boi05
Guest
 
Posts: n/a
Unhappy

Hey everyone....i am new to tha forum and tha proud new owner of a '93 9c1 caprice, hope to have pics posted soon. I have a couple questions tho that i thought u guys could answer for me, sumtimes when i go to start my car it doesnt crank at all...but if i go wiggle tha battery a little (there's a piece of wood in between tha battery terminals and tha post) it fires up, but then sumtimes it will cut rite bak off unless i give it sum gas. Has anyone ever had this problem?? if so tha solution would be greatful... And also, is it possible for a late generation thunderbird, tha ones built in tha early '90's to be faster than my car?? didn't seem rite but one outran me tha other nite.....any suggestions.....thanx guys [img]graemlins/.gif[/img]
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 11-15-2005, 09:03 PM
Dragon9c1
Guest
 
Posts: n/a
Post

Sounds like either you need a new battery or battery cables(Maybe just the terminals that connect to the battery)

I would take it to an AutoZone/Checker/Advanced/Schuck's/Kragen(some NAPA's) and have them check your electrical system for free.. Their test would tell you if it is, your battery/battery connections/Alternator/Stater/etc..
quote:
-------------------------------------------------
And also, is it possible for a late generation thunderbird, tha ones built in tha early '90's to be faster than my car?? didn't seem rite but one outran me tha other nite.....any suggestions.....thanx guys [img]graemlins/.gif[/img]
-------------------------------------------------
If it was a standard T-turd, then you should have taken it(if it had no mods), except your car isn't running right so that would slow you down...
Now if it was a T-turd SC( has a Super Charger, but I always thought it meant Super Chicken ), then it might beat you depending on the driver and its mods..

Also take and post pics of you battery set-up(with wood in place), if you still have problems..
post #3 of 6 (permalink) Old 11-15-2005, 09:26 PM
mrmarkus
Guest
 
Posts: n/a
Post

Welcome!
I too am new here,2 months ago I bought a 95 9C1,with the LT1 motor.
A piece of wood between the terminals and the post?That should not be there,I betcha the posts on the battery are cracked on the casing,and the ground may be at fault.If they are cracked,I'd replace the battery.Is the wood there to protect the battery,like a hold down clamp? If so,I'd remove it and get one from the auto parts store.

I'd check to see what motor is in there,if its the original or a replacement.Also,when was the car last tuned up,miles on the motor,transmission condition,the whole shebang.It sounds fishy that a T-bird beats out a 9C1.

Hope my .02 worth helps.I'm sure other guys here will chime in and they may know something I don't...
 
post #4 of 6 (permalink) Old 11-15-2005, 09:31 PM
stl_boi05
Guest
 
Posts: n/a
Post

Tha wood is there to keep tha battery from sliding around (was there already when i puchased) and i haven't had a tune up done since i had tha car, or oil change
post #5 of 6 (permalink) Old 11-16-2005, 10:38 AM
marion
Guest
 
Posts: n/a
Post

I have to go with yada on this one a T bird beating you is the wrong answer my 95 caprice with the L99 in it was beating 4.6 ltr mustangs with no mods done to it.
post #6 of 6 (permalink) Old 11-16-2005, 12:45 PM
89mikeSS
Guest
 
Posts: n/a
Post

About the t-bird. I'm 15, and I have a 91 caprice. My dad has a 91 wagon, and my mom has a 96 t-bird. My dad and I took the t-bird out to the local drag strip with our local impala club. Our t-bird has the v8 but isn't the SC. We kept up with our friend in his 95 impala all the way down the strip! I am always getting on my mom about driving a ford, but I have to admit that the t-bird is pretty fast. The impala was faster but if the caprice has just a regular 350 in it, then i think the t-bird might keep up!
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome