Just got a 91 Caprice, have a few ?? - Chevy Impala SS Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 02-09-2006, 06:39 PM
SiGuyUWP
Guest
 
Posts: n/a
Post

Hey all-

I'm new to the forums and new to owning a B-body. I bought a 91 Caprice LTZ off a good friend of mine for $1600 w/ 150K on the clock. Tranny is about two years old, and has a few nice parts (remote start, Pioneer CD player). Now on to the questions:
1) It leaks oil...looks like from the oil pan. How hard to replace, and anything to look out for or fix while I'm down there?
2) Anti-Lock warning light is on, and has been since my friend got the car in 2000. Any ideas where to start looking for a problem?
3) The car handles pretty well for being a land barge, but since the tires are fairly worn out I'm looking to replace them with something better. I was thinking along the lines of 235/50/15's on stock steelies. The original rubber is a 225/70/15. Such a large reduction in aspect ratio is going to throw the speedo way off, and I'm wondering if there is a way to re-calibrate it (its the digital speedo that says "Certified" over it).

All in all, it's a great car, and will be better when it get's the LT-1 swap at some point in life. (currently a 305 TBI). Thanks in advance for any help, and I look forward to hanging out on the site.

Scott
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 02-09-2006, 07:25 PM
DonutGuard
Guest
 
Posts: n/a
Post

If nothing's physically wrong with the ABS, and they work fine, it could simply need to be reset by a technician in the car's computer. Otherwise, have it looked at.

Personally I wouldn't change the tire size on it. The tire size they put on there stock is decent. I would personally go with BFGoodrich Radial T/A's if you could afford em, if not Dunlop D65 Touring Elites. I hear Kuhmo's are also very good, and priced rather well.
post #3 of 13 (permalink) Old 02-10-2006, 10:04 AM
hot70formula
Guest
 
Posts: n/a
Post

Greeting fellow cheddar head!

From my expereince with my old 91, (I had 198K on here when I finally sold her).

the abs thing, I had on forever. the anti lock brakes stopped working, but it braked just like a non abs car. The old abs system was actually more annoying I personally thought.

check your pvc valve and replace it. I found that mine would plug up and force oil out along the pan and intake. not a guarented fix, but you never know.

I ran stock size bfgs under mine and they worked good in the snow.

my car was more "sloppy" then 94-96 models in the suspension but knowing what i do now, some swapping of sway bars and a general rebuild of suspension, problably would have helped that.

welcome to the club
 
post #4 of 13 (permalink) Old 02-10-2006, 09:40 PM
armadamaster
Guest
 
Posts: n/a
Post

Welcome to the world of the B-body! I've do and have owned a few and I'd advise going no bigger than 235/70/15 on the tire size. Based on that tire size you listed, sounds like a 9C1 you've got there! Also, much bigger on tires will make getting them in & out of the skirts in back even more of a PITA IMHO.

Congrats and enjoy your purchase!
post #5 of 13 (permalink) Old 02-11-2006, 03:27 AM
egg white
Guest
 
Posts: n/a
Post

Long shot ,BUUUUT,did you change the 3rd brake lite bulb????I think that can put out the warning lite??? any buddy else know for sure?
The crs is strong *** morning,first cuppa java!EDIT,3rd cup now,I think its the cruise control that gets fixed by replacing the 3rd lite, sorry.
post #6 of 13 (permalink) Old 02-11-2006, 07:24 AM
waynes91
Guest
 
Posts: n/a
Post

have you look on the trunk lid inside should be a sticker with a bunch of letters and numbers some of the key ones would be 9C1 "police package" G80 means you have a limiled slip posi rear end, GU6 would means you have a 3;42 gear ratio etc, there other GU # for differnt gears, does your car have any oil type coolers up in front? mybe other can chime in on some other codes, like if it a 305/350, if u check the vin # the 8th digit over if its a 5 its a 305, a 7 its a 350. dont worry the mod's will start soon
post #7 of 13 (permalink) Old 02-12-2006, 10:21 AM
SiGuyUWP
Guest
 
Posts: n/a
Post

Hey all-
Thanks for all the responses!

Gomer- I don't know if anything is physically wrong (speed sensors missing or ??) but I'll have to look probably when it's warmer out lol.

Hot70- I'd kinda like the ABS because it is impossible to pump the brakes on this thing, I'll hit them and release but it takes like 2 seconds for the pedal to come back. It makes driving in the snow a bit interesting to say the least. I might be contacting you at some point for your thoughts on suspension, cause this thing could use some new parts underneith it. I see your in Freedom, which if I'm not mistaken is pretty close to Lodi, maybe we can meet up sometime.

The car is an LTZ, which my friend says is pretty much the police suspension, and he said it has a limited slip also. I will check the option codes and get back to you guys. I do know it has a 305 for sure though, because it is slow as hell compared to my brothers old 94 Imp SS. Is there a database or something that explains what all the option codes are?

Thanks again for all of the help!
post #8 of 13 (permalink) Old 02-14-2006, 03:23 PM
ChevyChugg
Guest
 
Posts: n/a
Post

do you go to UWP?? just curious cause of your name
post #9 of 13 (permalink) Old 02-14-2006, 05:47 PM
SiGuyUWP
Guest
 
Posts: n/a
Post

Yeah, I did. Graduated in May, now I live in Lodi, near Madison. If you went there you might recognize the car, it was my roommates car which he drove from 2000 until December, when I bought it from him.

Edit: Mine looks just like the one in your sig, same paint job at least. But it has the spoked hubcaps not Imp rims.
post #10 of 13 (permalink) Old 02-14-2006, 07:36 PM
ChevyChugg
Guest
 
Posts: n/a
Post

I think I saw it 2 yrs ago, but it had no hubcaps at the time? I don't have the impala rims anymore though, I ran into some financial issues and had to sell them. [img]graemlins/1.gif[/img]
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome