Has anyone replaced springs? - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 12-09-2002, 08:07 AM
Orange 01 SS
Guest
 
Posts: n/a
Post

Here's the deal. Over the weekend I had a lot of work done on the front suspension on my '93 Caprice. It has over 200,000 miles on it, and I was worried about having a wheel collapse on it.

Here's what I had done:
New Shocks
New Upper/Lower Ball Joints
New Tie Rod Ends
New Idler Arm

Springs

I put the springs on because they are supposed to be off of an Impala SS (they were used), and I wanted it to sit a little lower (it has a lot of miles, but I like it and still care how it looks). Now it sits like two inches higher than it did with the stock Caprice springs! I hate it. I hate it! I HATE IT!!!

The guy that did the work for me is a pretty nice guy and a good mechanic, and he thinks then springs will settle. I am not that convinced. Do springs sit higher when they're first put on? I think it could be possible that the springs are not what was advertised.

Otherwise, the old car sure drives nice!

Thanks for any help or thoughts on this.

Craig [img]0.gif[/img]
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 12-09-2002, 08:15 AM
96capriceMGR
Guest
 
Posts: n/a
Post

Try taking a look at the springs there should be a paper tag with 2 large letters and some smaller numbers, even just the letters should help us sort this out. While you are there try to verify that the springs are indexed properly and maybe measure height to the bottom of the wheelwell trim in front and give us your tire size.
post #3 of 9 (permalink) Old 12-09-2002, 08:21 AM
Orange 01 SS
Guest
 
Posts: n/a
Post

I'll try and look at them later, but I don't remember there being any kind of paper tag on them when I was looking at them outside of the car. [img]8.gif[/img]
 
post #4 of 9 (permalink) Old 12-09-2002, 10:02 PM
CapriceCarsLT1
Guest
 
Posts: n/a
Angry

Is your car a 9c1 police package or civilian?
You may have gotten police springs instead of impala SS Springs. I heard it happen to a guy here locally. The car will not level off later.Either they are in wrong or you got the wrong springs.
post #5 of 9 (permalink) Old 12-11-2002, 10:57 AM
booth9c1ss
Guest
 
Posts: n/a
Post

Last year I took the 9C1 springs off my car and put on WX3 springs (actually a shop did it). The result was that my car sat 1/2" higher with the Impala springs. A few weeks later i took those out and put in cut 9C1 springs (1 coil removed). The problem was that the [incompatent] shop didn't seat them properly.

Picture of my car with improperly installed Impala SS springs

If you look uder the car at the lower A-arm, you will see two holes in the bottom of the spring pocket. One should be open (not covered) for drainage. The other one should be covered by the spring. Mine were 180 degrees out and resulted in raising the car +/- 3 inches!


This is with the cut springs...installed right.

Steve
post #6 of 9 (permalink) Old 12-11-2002, 12:26 PM
Orange 01 SS
Guest
 
Posts: n/a
Post

Thanks, guys!

Yep, it sits just about like booth's green car.

I'm planning to take it back to the shop this weekend. If we can't figure out that the springs are in wrong, I'm going to have him cut a coil out of the stock springs and assume I was sold 9C1's or something different than advertised.

Of course, if I had wanted to cut the springs, I would have done that in the first place and not bought the others to try and do it right!

Anyway, thanks for the help. I'll check the position of them Saturday. [img]smile.gif[/img]
post #7 of 9 (permalink) Old 12-16-2002, 11:17 AM
Orange 01 SS
Guest
 
Posts: n/a
Post

Well, I took it back and we cut 3/4 of a coil out of the new springs. Lowered it pretty low, actually, but it looks good to me. It wasn't easy, thoguh, because the cut spring kept wanting to rub on the frame, so it would make noise. It's good now, though. [img]4.gif[/img]
post #8 of 9 (permalink) Old 12-16-2002, 11:18 AM
Orange 01 SS
Guest
 
Posts: n/a
Post

Holy crap, that Emoticon is big ...
post #9 of 9 (permalink) Old 12-16-2002, 07:20 PM
renoman
Guest
 
Posts: n/a
Post

Whoa!! Man, I thought I was looking in the mirror when I saw that.

Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome