Finally; "New Front Suspension" - Chevy Impala SS Forum
 1Likes
  • 1 Post By Deputy347K9
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-09-2016, 03:04 PM Thread Starter
Senior Member
 
Join Date: Nov 2004
Location: Cherry Point, NC
Posts: 340
 
Garage
Finally; "New Front Suspension"

Finally gatta done! RMP Motorsports out of Garner, NC did the install for me. I did have a fairly new GM steering shaft and was riding on Koni adjustable shocks with a Herb Adams front sway bar. Other than that everything was 1996 stock!

Replaced all upper and lower control arms with tubular control arms manufactured by Speed Tech out of Utah. Set of Viking coil over shocks with a HD Moog complete rebuild. Last but far from the least was a stainless steel steering shaft by Flaming River. The install went as advertised though there was one small problem.

With the new tubular control arms you receive a new set of alignment specifications. The new specs are as follows; driver side camber 0 to 1/2 degree negative, passenger side the very same. Caster on driver's side is 4 degrees positive and 4 1/2 on the passenger side. Total toe-in being 3/32nd for both sides.

On the alignment we got 0.0 camber for the driver's side and negative 0.8, caster came out at 6.9 degree positive on the driver's side and 7.1 on the passenger side. Toe in was great.

Telephoning Speed Tech with the results they were only concerned with the camber, wanting me to lower the passenger side by 0.3 so we would be in the 1/2 degree negative. Problem is the control arm shaft is setting against the frame with ZERO shims. The only way to get the control arm out that smalls amount is to shave the control arms shaft 0.10, this would reduce the camber to about 0.2 negative or max 0.3. This will be perfect!

I believe the problem is the ball joint mounting holes in the upper control arms is a tad larger than the actual 9/16" ball joint bolts, I am assuming to accommodate the 5/8th joints. I could have popped the ball joint and tried to move it outward a bit but didn't want to get caught with my pants down, what if there was no extra space than I would be at square one again. Speed tech is sending me another upper control arm shaft that they will mill 0.10, will have new bushings. Will install than realign.

Being the specs are so close I drove it home while really concentrating on the handling. Of course thee is zero play in the wheel, tracks perfect, no pulling left or right. I am running Goodyear Eagle F1 GS D3 tires, 275/40/17 front and 315/35/17 rears. With a 150 mile trip I found I increased the speed as I felt more confidence. I don't want to change the caster a bit, she settles in the curves perfectly, zero leaning and when hitting the throttle at the apex she comes out perfectly.

Over all the one issue that will be corrected. I am very happy I went all out and done this change. It's surprising how much handling performance we loose over the twenty years!

At this time I am on the road with a friend looking at a new "Dodge Hell Cat", not for me that's for sure. My buddy is really into the Chrysler products and ordered one. 707 factory HP!

Will be home tomorrow to take the Impala out on the road at the temps are in the upper 70s!

Larry

Larry
Toms9C1 likes this.
Deputy347K9 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome