Lowered my FWB now vibration at 45-50mph? - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-10-2016, 06:21 PM Thread Starter
Senior Member
 
Join Date: Dec 2014
Posts: 108
 
Lowered my FWB now vibration at 45-50mph?

looking for some help here guys decided to lower the car with some sprint springs and the car had a lil vibration before but nothing that was bothering after lowering car i took it for a spin and accelerating 45-50mpg it has this shake this is getting into gas a little more then half throttle. it also did it on deceleration at the same speeds. Speeds lower then what i have listed you dont feel it and once you get to highway speeds you do not feel it either. Could i have a driveshaft issue here? tires arent of brand but have good tread 15" .
i dont feel it in steering but i do feel it in my a$$ and its also noticable that the driver side headlight is shaking as well.

any help would be great
lswagon is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-10-2016, 08:56 PM Thread Starter
Senior Member
 
Join Date: Dec 2014
Posts: 108
 
"This was before lowering car"
i also would like to add that i also noticed that the previous 2 times i removed driveshaft i had noticed it was hard to pull out. the first was to do the gears i lifted rear of car let rear hang removed ujoint straps and pried forward thinking i would get the usual give forward a lil and nothing i ended up having to put trans in nuetral and remove both ujoint caps and rotate shaft in order to free it from pinion. the second was when i dropped trans to install convertor with front of car up in the air i removed u joint straps and driveshaft would not come forward only like 1/2" i had to pull off ujoint caps and rotate shaft with trans in nuetral in order to get it out of the pinion...

could my driveshaft be to long to begin with???Then with the lowering of the car it runs the shaft even deeper into the trans. This is the first time ive had this issue. forgot to mention the hassle with the driveshaft but i feel its important
lswagon is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome