Metco lca & Icm's installed! - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-26-2004, 01:20 AM
Billet SS
Guest
 
Posts: n/a
Post

It took from 7pm until 1am to get it right [img]graemlins/4.gif[/img] but I can really tell its a difference,details tomorrow
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-27-2004, 10:13 PM
BoneSStock95
Guest
 
Posts: n/a
Post

Wheres the pics? Id like to see the eye candy please. Thanks.
post #3 of 4 (permalink) Old 08-28-2004, 07:24 PM
96roadmaster
Guest
 
Posts: n/a
Post

Now do a burnout and let us know about the axle hop.
 
post #4 of 4 (permalink) Old 08-28-2004, 09:24 PM
Billet SS
Guest
 
Posts: n/a
Post

I dont have pictures,but there the new lca's that are 30% lighter than the old ones.I never really had wheel hop,it just spent the tires alittle to much(right to second gear)now it spins very little and takes off.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome