ABS light on after suspension upgrade - Chevy Impala SS Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 04-05-2004, 09:38 AM
SAImpala SS
Guest
 
Posts: n/a
Post

Hey guys, Question,
I just finished putting on new lower and upper ball joints, A-arm
bushings. After re-assemble my ABS light is now on on the dash.
When I took the passenger side ABS sensor off it was very stuck and
hard to get out of its hole. I knocked it out with a small socket
and hammer. It is still intact, but my ABS dash light is now on. Could I
have damged the ABS sensor? If so, hoe can I fix it or other ideas?

If it is the ABS sensor. Can I just purchase another sensor and wire it in?
Thanks.
SA.
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 04-05-2004, 01:07 PM
AutocroSSer
Guest
 
Posts: n/a
Post

Most likely, you destroyed the sensor.

Coat the new sensor housing with anti-sieze before installing it, and you should (hopefully) avoid it sticking again).
post #3 of 11 (permalink) Old 04-05-2004, 02:07 PM
SAImpala SS
Guest
 
Posts: n/a
Post

Thnaks Ed,
I'll order, I guess two of them, one for each side. I do not know which might be faulty.

Is this ABS sensor just as simple as cut the wires, and re-wire and replace with a new ones?

Thanks again.
Stephen
GASSIT #27
 
post #4 of 11 (permalink) Old 04-05-2004, 02:13 PM
Mr pogo
Guest
 
Posts: n/a
Post

New sensor should come with harness, do not ever cut sensor wires! Youll have to trace to where it plugs into rest of car, usually around the frame.

Also if you were to check the ABS blink codes you would be able to pin it down to which individual sensor is bad if that was the case.
post #5 of 11 (permalink) Old 04-05-2004, 02:30 PM
SAImpala SS
Guest
 
Posts: n/a
Post

I have not messed with the "ABS blink cose" but I am assuming by use the diagnostic port, I can make it flash a code.....? To get to the blink code?

Stephen
post #6 of 11 (permalink) Old 04-05-2004, 03:23 PM
Mr pogo
Guest
 
Posts: n/a
Post

Hmm, checking the FSM doesnt show blink code procedure at least for 96s. Which is strange as I have pulled codes before out of other similar GM ABS systems. I will do some research tonite at work and check my FSMs I have there.
post #7 of 11 (permalink) Old 04-05-2004, 03:38 PM
AutocroSSer
Guest
 
Posts: n/a
Post

Pogo : need a real scantool (i.e. not a glorified paper clip that costs $30 at the parts store) to pull codes on any of the 94-96 cars.
post #8 of 11 (permalink) Old 04-05-2004, 04:06 PM
SSoMad
Guest
 
Posts: n/a
Post

If you follow the wire from the sensor you will find a connector clipped to the frame, it just unplugs.
I made the same mistake once when I was changing spindles, then I ordered new sensors and saw that they had a connector.
If I ever remove a spindle again I will just unplug the sensor and leave it in.
I completely destroyed a sensor when I tried to remove it, I swear it was epoxied in.
I honed out the hole for the sensor so it was an easy slip fit for the new ones.
Rich
post #9 of 11 (permalink) Old 04-05-2004, 08:05 PM
SAImpala SS
Guest
 
Posts: n/a
Post

Thanks for the comments. I think after reading these my sensor is probably bad now that I forced it out with a small socket. It did not want to come out. I'll call Dal tomorrow. Thanks again.

In the mountians of TenneSSee. Just north of Ed's old stomping ground.

Stephen
post #10 of 11 (permalink) Old 04-06-2004, 01:56 AM
Mr pogo
Guest
 
Posts: n/a
Post

After going thru another model FSM looks like GM deleted the Diagnostic Request terminal off the ABS ECM.
That soitenly sucks
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome