lower ball joint install problem - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-13-2004, 05:45 PM
93wagonman
Guest
 
Posts: n/a
Post

I just got my control arms back from the local speed shop, Steve Ashworth Performance. They were going to install my new bushings (no problem) and my lower ball joints. I go to get them and they say the BJ's are too big and they couldn't get them in. They got them like half way and stopped, took them back out. I measure the holes in the LCA's both are the same;
Largest diameter- 2.082"
Smallest Diameter- 2.068"

The ball joints are from PST (TRW's) they are the same at 2.095" I checked them against another set of TRW's at Advanced Auto and they are the same. I have a large hydraulic press at work so I was thinking about trynig to do this myself. Does anybody know if these numbers all seem right? If they do is there anything I shuold do to press these in like heat the arm or if these numbers seem bad what should I do now?

Thanks
Nick
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-13-2004, 05:57 PM
Spartus
Guest
 
Posts: n/a
Post

So the hole in the arm is .013" smaller in dia. than the Balljoint? Wow..

Went out in the garage and measured one of mine. 2.080" ID on the arm.... 2.094" Od on the balljoint... I think that's why they call it a press fit.

Tell the guys at the other shop to get a REAL press. My press had no issue at all with pressing the balljoint in.... It's a 12 ton BTW.
post #3 of 4 (permalink) Old 02-13-2004, 05:58 PM
AutocroSSer
Guest
 
Posts: n/a
Post

If I had to guess, you got the 5/8" balljoints (from late 95 and all 96 9C1) but your spindles/control arms are set up for 9/16" balljoints.

Edit : ok, saw Tom's reply. Try that first
 
post #4 of 4 (permalink) Old 03-01-2004, 08:01 AM
93wagonman
Guest
 
Posts: n/a
Post

FYI,
I took my LCA's and ball joints (the same ones described above) to a race shop that I used to work on the car. I put them in with another guy who works on the car in less than 30 minutes. I have no idea what the problem was for the good folks at Steve Ashworth Performance (Fuquay-Varina, NC). They may be good engine builders but I seriously question their suspension competence. I also had to go back thru and seat 2 of the 4 bushings in the LCA's, remove the inner bushing because they didn't grease it and I am going to take off the upper control arms now because I don't have a lot of confidence that they greased those properly either.
Close to finished now though. Maybe by next weekend.

Nick
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome