Poly Swaybar bushings was what caused my major squeek - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-15-2004, 02:25 PM
SSlumpin Imp
Guest
 
Posts: n/a
Post

Just wanted to post this to let the guys know who are looking for your front end squeeks like i was for so long. I first thought that it was my bilsteins because they are known to squeek when the bushings are installed improperly so i ended up removing them twice and lubing them to make sure it wasn't them but it never did anything.
the other day when i was putting in new o2's, i pulled myself out from underneath the car using my swaybar and i heard a quick squeek so i took a look at my bushings and for some odd reason, i got the idea that they were cracked so i immediately ordered new bushings with the fiber linings from dal p/n 10288551. Yesterday i put them in and i had a hell of a time. Turns out my HA bushings were fine but i said screw it, i'll put the new ones on anyway and it was a BIATCH to get them on. I had to reuse my stock bushing straps but they worked. I greased up my endlink bushings and i was done
Diagnosis... annoying/embarrasing MAJOR squeek is completely eliminated

Just a heads up for people trying to track down squeeks and havent checked these
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-15-2004, 10:50 PM
fro SS
Guest
 
Posts: n/a
Post

Were these greasable poly bushings? If so, how often did you grease them? If not, did you grease them up with the provided tube of lithium grease prior to installation?
post #3 of 3 (permalink) Old 08-16-2004, 01:35 AM
SSlumpin Imp
Guest
 
Posts: n/a
Post

yeah they were greasable and i did grease them up before i put them in and after a couple thousand miles. Guess it was just my luck or something but they were squeeking BAD... Great to drive the car without having to worry about the front sounding like crap over bumps
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome