Sway Bar or NO sway bar - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 03-08-2004, 10:24 PM
BadNewsSS
Guest
 
Posts: n/a
Post

Ok, so I drive on the street, and drag race on the weekends, instead of yanking the sway bar every weekend, what will happen if i leave it off, i do enjoy corners while road driving, but i am not road racing by any means. Any thought as to weather i should keep it off, or just take it off at the track, and then re-install??? Or is it really not changing that much by taking it off at the track?? my 60 foot times improved from a 2.21 with, and then from 2.18 down to 2.12 without?? Is that a measurable difference?
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 03-09-2004, 07:37 AM
tbsimmons
Guest
 
Posts: n/a
Post

I just went this weekend, on Drag Radials, and got a 1.83 60' with HO bars all around.
On street tires the best I got was a 2.04, I didnt take them off there either.
post #3 of 7 (permalink) Old 03-09-2004, 12:03 PM
FUN 9C1
Guest
 
Posts: n/a
Post

I took mine for a spin once with no front sway bar, and there's no way in hell I'd drive it like that if I didn't have to. Front end dove to the ground just normal turning. But try it and see if you can live with it. New end links are only like $17 for a good pair.
 
post #4 of 7 (permalink) Old 03-09-2004, 12:32 PM
FAMILY TRUCKSTER
Guest
 
Posts: n/a
Post

Take it off for a week and try it, if I drove my wagon more than just to the track, I would definately leave it on.
post #5 of 7 (permalink) Old 03-09-2004, 08:02 PM
SSpiffy
Guest
 
Posts: n/a
Post

With only a rear sway bar on, you have seriously compromised your emergency handling capability. If you have to make a sudden, severe turn to avoid something, the car is likely to swap ends.
post #6 of 7 (permalink) Old 03-09-2004, 09:02 PM
D.Grimm
Guest
 
Posts: n/a
Post

I'd leave it on. Unless you go to drag race valving on your front shocks to gain weight transfer, the front bar won't hurt you too much.
post #7 of 7 (permalink) Old 06-20-2005, 11:08 PM
rufus
Guest
 
Posts: n/a
Post

Just disconnect the end links when you get to the track. Race, bolt them back. Seems to work for me.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome