left wheel squeak - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-15-2004, 04:37 PM
95SuperSport
Guest
 
Posts: n/a
Post

hopefully this is an easy answer... when i make a left turn the left front wheel makes a consistently and repetitive squeaking sound. its always happened just finally thought to put it up here. I did just rotate the tires, however, and it still does it...thanks for any help
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-15-2004, 04:44 PM
vandal835
Guest
 
Posts: n/a
Post

Is it a tire squeak? How sharp of a turn where you making?

Is it a belt squeak? The water pump could be leaking on the belt beauce an extra load is put on the belt while PS pump while turning.

High pitched squeak? When where the brakes last checked?

I have a squeak like that on the right wheel.. And not the left wheel also on my 95 SS.

I think this is being caused by bad wheel bearings and worn pads. Monday I get my parts!
post #3 of 4 (permalink) Old 07-17-2004, 09:16 PM
95SuperSport
Guest
 
Posts: n/a
Post

Its not from cornering too hard or braking. It just squeaks when I turn left above 20 mph.
 
post #4 of 4 (permalink) Old 07-17-2004, 09:17 PM
95SuperSport
Guest
 
Posts: n/a
Post

water pump is 1 year old too and no signs of leaks....maybe the bearings??
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome