Is it the power steering? - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-16-2003, 03:13 PM
Rex Monaco
Guest
 
Posts: n/a
Post

I have a '96 Fleetwood. While driving, it would feel like I hit an ice patch and the wheel would turn real easy for a second.

Then, it started humming from 0-5mph. The brake pedal also vibrates.

It was low on power steering fluid. That stopped the ide patch symptom, but that doesn't seem to have eliminated the noise of vibration.

Any ideas before I replace the power steering pump?

Also the FW has variable assist. Can I use an SS pump?
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-16-2003, 08:27 PM
DrMaxim
Guest
 
Posts: n/a
Post

I have run into a situation similar to this and found out it was my harmonic balancer slipping. I noticed that my volts would drop a little at the same time. Just a thought. Run a chalk mark across the front of the pulley and drive for a couple days and see if it has slipped. I would only have to start and rev mine and it would move A LOT.

Free to check and cheaper than a power steering pump.
post #3 of 3 (permalink) Old 08-17-2003, 07:12 AM
Rex Monaco
Guest
 
Posts: n/a
Post

Cool, thanks I'll do that today.

Long term, anyone know if a Fbody pump would be a simple bolt on option for my Dbody?
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome