suspension jitters going fast - Chevy Impala SS Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 09-18-2004, 09:20 PM
96BigBlackBeauty
Guest
 
Posts: n/a
Angry

OK, I re-did my whole front end and changed my shocks to the "stiff" bilstiens but still have the stock springs. It rides perfect, BUT only when I'm going slow below 50 MPH. Above 50 MPH and on the freeway where it has the semi-pointy concrete slabs every few feet its gets jittery and rough. It dont think its a balancing problem because if the freeway is straight then its just flying. My theory, it might be stupid but I'm not an expert on shocks and springs, is that since the springs are soft it can't push out the shocks fast enough and it rides rough. What you guys think and how should I fix it.
Thanks
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 09-20-2004, 07:05 PM
GM Tech
Guest
 
Posts: n/a
Post

Well, first can you define jittery and rough? Sounds like my x. But seriously, does it feel too responsive? The rough ride is from the stiff shocks. They would dampen movement quicker and allow less travel in the same situation that would allow older cars to gently "float down the road"

When you say you "re-did your whole front end" what all did you do/have done?
post #3 of 11 (permalink) Old 09-20-2004, 08:09 PM
96BigBlackBeauty
Guest
 
Posts: n/a
Post

Quote:
Originally posted by GM Tech:
Well, first can you define jittery and rough? Sounds like my x. But seriously, does it feel too responsive? The rough ride is from the stiff shocks. They would dampen movement quicker and allow less travel in the same situation that would allow older cars to gently "float down the road"

When you say you "re-did your whole front end" what all did you do/have done?
I would define it as rough and bouncy. As for the front end rebuild I got the PST rebuild kit and installed eveything. Do you think by getting "softer" shock I can fix this?
 
post #4 of 11 (permalink) Old 09-20-2004, 08:36 PM
AutocroSSer
Guest
 
Posts: n/a
Post

Rebalance your wheels
post #5 of 11 (permalink) Old 09-20-2004, 11:06 PM
96BigBlackBeauty
Guest
 
Posts: n/a
Post

Quote:
Originally posted by AutocroSSer:
Rebalance your wheels
Would the problem still be balancing even though when I'm driving 80 on regular asphalt its perfect? It just when the road is uneven (ie freeway concrete slabs) or has cracks that it gets rough.
post #6 of 11 (permalink) Old 09-21-2004, 12:15 PM
AutocroSSer
Guest
 
Posts: n/a
Post

OK, if it goes away on smooth freeway then it probably isn't tire balance.

Is it a constant jitter every time you hit a bump, or is it only SOME of the time?
post #7 of 11 (permalink) Old 09-22-2004, 02:53 AM
96BigBlackBeauty
Guest
 
Posts: n/a
Post

Quote:
Originally posted by AutocroSSer:
OK, if it goes away on smooth freeway then it probably isn't tire balance.

Is it a constant jitter every time you hit a bump, or is it only SOME of the time?
It happens every time I hit an unleveled cement, which on the 405 freeway is a lot. It feels like a plane in light turbulence.
post #8 of 11 (permalink) Old 09-22-2004, 10:54 AM
AutocroSSer
Guest
 
Posts: n/a
Post

I'd check to see if something is loose, especially since you just re-did the front end.

This does NOT sound like shock over-dampening to me. My old WRX setup (coilovers, with dampeners that did a lot more dampening than any shock I've seen available for the B-body [img]smile.gif[/img] ) was overdamped....it was jittery over rough roads, but at LOW speeds. Actually rode decent at 50-80 MPH, but the ride (on the same road, i.e. a chopped up road or freeway) absolutely sucked at 20-40 MPH.
post #9 of 11 (permalink) Old 09-22-2004, 12:01 PM
allen89
Guest
 
Posts: n/a
Post

Have you checked your front end alignment, also what tires,wheels and air presssure are you running. That could have some effect. On a recent trip I forgot to turn the QA-1's down after autocrossing and when I hit a stretch of rough pavement at Impala speed, I thought I was going to loose a filling or two but there was no loss of control or floating just a rough ride.
post #10 of 11 (permalink) Old 09-22-2004, 03:57 PM
Navy Lifer
Guest
 
Posts: n/a
Post

96--

What wheels/tires do you have on the car?
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome