Need Help! - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-21-2004, 10:57 AM
eliteusmc
Guest
 
Posts: n/a
Post

HEy guys just redid my front suspension when I jack up the driver sided only and move the wheel left and right with my hands I have a fair amount of play. When I move the wheel up and down there isnt any wheel play at all. Is there something wrong with my rebuild ?
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-21-2004, 11:26 AM
uncle hulka
Guest
 
Posts: n/a
Post

Hey Elite! Sounds like classic idler arm to me...
Possible center link also. Were These replaced??
SEMPER FI
post #3 of 3 (permalink) Old 02-21-2004, 07:04 PM
eliteusmc
Guest
 
Posts: n/a
Post

No all the suspension except the idler arm was replaced. The passenger side wheel is solid but the driver side moves left to right when it is jacked up. I replaced all the suspension ball joints end links centerlinks, gear box, A-arm busings top and bottom. Along with rear upper and lowers. I also have a drift problem, when I give it gas it kind of goes to the left when i let off of the gas it pivets to the right then straightens out. It feels like the body is loose or something. But I didnt have that problem before the matco uppers and lowers. I looked and pryed underneath the rear and she is SOLID so maybe the loosenes is the rearend. Do you guys think a POSI might fix the problem.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome