High-pitched noise from suspension - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-21-2004, 10:33 PM
dogma
Guest
 
Posts: n/a
Post

93 caprice with 170K miles

It doesn't appear to be an engine thing. Doesn't happen at idle if I rev the motor, only when it is moving, whether I am hitting the gas pedal or not.

Seems to come from the left front.

Is one of the struts shot? Ball joints? What could it be? Performance is not affected.
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-22-2004, 09:21 PM
Roadmonster96
Guest
 
Posts: n/a
Post

Your car does not use struts, so you can count that out, but i would check to be sure everything is greased, then check bushing wear, and all joints, ie ball joints, tie rod ends, sway bar, just check in that area where you hear the noise, let us know.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome