squeak squeak...definitely SB bushings... - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-08-2004, 09:37 PM
'94XTHP
Guest
 
Posts: n/a
Post

My front suspension is squeaking. Although the control are bushings could be better, they're not squeaking. With the hood open, I can push down on the bumper, and put a hand on the swaybar. You can "feel" the squeak in the bar itself, and identify that that is the source of the bad squeak. My car has HO Racing sway bars front and rear. The bushings appear to be in good shape, and installed correctly. They aren't bulging out of the brackets or anything. The endlinks look good as well. I did a search first, but I'm still not sure what to do to stop this.
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-08-2004, 09:48 PM
uncle hulka
Guest
 
Posts: n/a
Post

Well, VIN, if the bushings are urethane, you
can simply grease them. This is REQUIRED with
a urethane bushing.
BTW, my UCA bashings were shot, the squeak was
unbearable..
EDIT Just looked your sig over again... your car
is indentical to mine except the SLP hood.
post #3 of 4 (permalink) Old 04-08-2004, 10:05 PM
'94XTHP
Guest
 
Posts: n/a
Post

They look to be urethane. Do I need to remove the endlinks first, then drop the brackets, or just unbolt the brackets? I know I need new bracket bolts, since I didn't install the bar, and don't know if they used torque-to-yield or not. Any special type of lube that stays better, or just plain ol' chassis grease?
 
post #4 of 4 (permalink) Old 04-08-2004, 11:47 PM
uncle hulka
Guest
 
Posts: n/a
Post

You can probably get away with just taking
the clamps off, remove both and pry the bar down.
Worked on mine, anyway. Just plain grease should be O.K. On my Jeep I used a silicone chassis grease.
I lube it once a year and no probs. yet.
If you find torque-to-yield bolts in there, I'd
replace them.
HOPE THIS HELPS!
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome