Pics of HA Front Bar install - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-04-2004, 08:52 AM
ak96
Guest
 
Posts: n/a
Post

Anyone (Ed?) have pictures of their installed HA bar with the tie rod ends? I'm curious if I've got this thing in right - I'm getting ready to rip most of the front end components off and Moog it, figure I should make sure I have it in the right way.

The reason I ask is that in checking everything out yesterday I noticed that the bar is rubbing on the frame rails, where the bar turns toward the tie rod ends. Almost seems like the middle (straight) section of the bar should be like an inch longer.

Yeah, it *has* been installed for like 6 years, so?


AK
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-04-2004, 12:51 PM
AutocroSSer
Guest
 
Posts: n/a
Post

Don't have them, because I don't have that bar,
post #3 of 4 (permalink) Old 03-04-2004, 01:43 PM
shiggins
Guest
 
Posts: n/a
Post

I don't have any pictures online, but can send you some or put them online. I have the HA installed to were the end of the bar were the link attaches curves down in relation to the mounting point on the frame. I have always had a slight rub on the stock SS wheels when turned to the lock, but hopefully this will be resolved once the Forgelines (racing season has started and they are backlogged) for the fronts come in.

I had to cut the springs when I installed the LS1, but I cut too much (full coil) and I am now right at the bump stop at rest and the HA bar is very close to rubbing the frame at the mounting point. I have some new Hotchkis springs and Del-a-lums, but have not installed them yet. I am working on fabricating some new a-arms (at least the uppers) to correct the camber curve.

Longer would reduce the roll resistance, which would probably be better. Most people donít like the HA on the front because they feel it provide to much roll resistance.
 
post #4 of 4 (permalink) Old 03-04-2004, 05:54 PM
ak96
Guest
 
Posts: n/a
Post

And all this time I thought you had the HA bars...

Scott, if you can send me the pictures I'd appreciate it.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome