Front swaybar bolts revisited - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-26-2003, 01:11 AM
eqs_ss
Guest
 
Posts: n/a
Post

I have read the previous solutions on the front sway bar bolt problem. All good ones but here is another.

The problem: The front sway bar bolts strip the threads on the frame when removed or when being threaded on. Even if you are using new front bolts as recommended there is a good possibility of stripping the threads on the frame. If the passenger side bolt holes are stripped you can put washers and nuts through the access holes already on the frame so that the bolts can be tightened. BUT if the threads on the driver side are stripped you are pretty much hosed. There are no access holes to thread a nut on to the bolt.

My solution: On the driver side I drilled one 1" access hole for each bolt in the frame. For the front bolt I drilled a 1" hole to the left of the current drain hole in the frame. The drain hole is located on the bottom of the frame to the left of the bolt hole.
Once that hole is drilled you can now access the bolt and you can thread a nut on the bolt.
For the rear bolt I drilled a 1" hole right behind it on the bottom of the frame. The gap between the rear bolt hole and the 1" access hole is about 1/2" to 3/4". Now you can access the rear bolt with no problem.

These new access holes also allow proper drainage of the frame.

I used stainless steel bolts nuts and lock washers.

Tools:

-You need a 1" or 1 1/2" hole cutter with drill bit guide
-Electric drill

Just another solution to a somewhat annoying problem.

Ernest
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-26-2003, 12:36 PM
SSSSnyder
Guest
 
Posts: n/a
Post

I did the "tie a thread to a bolt and work it inside the frame so it is sticking out" method. I used smaller bolts (I think 3/8 x 1.5" vs. the original 10mm) so they would slip past the existing threads in the hole and although they should be tack-welded to the frame to hold them in place, I was able to thread and tighten the nuts on the brackets without doing it. For the back hole on the driver's side I used 2 threads on the bolt, one at either end, so I could use tension on the back side to get the tip to wiggle into the hole. Took a couple tries to get it right on the driver's side, but not a huge deal at all. Happy to know that my sway bar brackets are on there but good.
post #3 of 3 (permalink) Old 10-01-2003, 06:32 AM
sleepercaprice1
Guest
 
Posts: n/a
Post

I stripped my bolt holes when I installed my front sway bar and tapped the frame for 7/16" threads and used a bolt similar to a header bolt- (reduced head). It cleared the mounting bracket just fine. If that hadn't worked, I was going to drill the frame out and weld in nuts. That would give you much more thread depth.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome