What's that noise? - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-13-2004, 01:51 PM
SSmoothCherry
Guest
 
Posts: n/a
Post

I put some Hotchkiss springs and billstein shocks on about two months and a half ago. Over the past three weeks or so when I drive my impala I have been noticing a loud popping noise coming from my passenger side around the wheel well area. It happens somtimes when I hit a little bump or even when I turn sometimes but not when I am riding on smooth surface. Does any body know what might be the problem
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-13-2004, 05:10 PM
GODSPEED
Guest
 
Posts: n/a
Post

did you check the rear control arms, hopefully the rear springs were put on correctly
post #3 of 3 (permalink) Old 07-13-2004, 09:01 PM
SSmoothCherry
Guest
 
Posts: n/a
Post

Well if I take the wheel off what should I look for to show that it was put on right. SHould I compare both sides. I drivers side doesn't make any noise and seems fine.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome