Loose Bilstein? - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-01-2004, 04:41 PM
Imalabil
Guest
 
Posts: n/a
Post

I was "shocked" to find while replacing my rear rotors that my driver's side shock has some play when I grabbed it in the center and pushed back and forth perpendicular to the shock axis.
I can't seem to isolate where the play is coming from; all bolts are tight at top and bottom and it doesn't seem like the rod is moving relative to the body. My best guess is where the rod mounts at the top--perhaps a swage loosened or something.


Bill
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome