Wandering etc - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-19-2004, 09:09 PM
ElTenorSupafly
Guest
 
Posts: n/a
Post

Well, the car used to wander to the left a lot.
So I took a trip down to the front end shop after I put my SS springs and SS wheels with brand new BFG G-Force KDWS tires on (on my previously stock 95 9c1)...
Got my alignment done, all's good. Inspect my tires 2 months later, and my passenger front tire is completely bald on the inner edge. Took it back to him, and he worked on it again. Said he "knocked some shims out" and to "come back when you get new tires"....

What is going on here? He aligned it, but it roasted my tire... is my suspension shot? Because he didn't mention anything when we asked.
Thanks


Also, my front suspension is ridiculously loud. It makes weird noise (popping, creaking, groaning) when slowing down, when turning wheel while going slowly, while accelerating. Very annoying, makes the car look like a piece of garbage
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-20-2004, 01:23 AM
AutocroSSer
Guest
 
Posts: n/a
Post

OK, I'll ask the standard question I always ask here

WHAT are your alignment specs RIGHT NOW?

Without that, tough to tell what is going on here.....
post #3 of 3 (permalink) Old 07-20-2004, 10:58 AM
mrthump77
Guest
 
Posts: n/a
Post

Is the Alignment shop reputable? I'd think he would check your f.e. before he even attempted to align your car. He could see what, if any, components are bad and tell you that your car wont hold alignment if you dont replace certain parts.

If it is the case, a f.e. rebuild would be like a new mod. You would feel the difference night and day. You would most likely get those squeaks/groans out. You also have to make sure you keep everything greased up.

As for all the creaks, I had that solved with the rebuild. However, the rear end also made a lot of noise. On launches, the car sounded like it was a bag of nuts & bolts. Changed my LCA's and sway bars and it solved that problem.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome