WS6 Front Sway Bar. - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 02-06-2004, 04:57 PM
LT4SS
Guest
 
Posts: n/a
Post

I got the bar for free from one of my Buddy's it came of 79 T/A WS6 and powdered coated it in glossy black, so i did my home work and searched and searched what i found out after the search that this bar is best if used with HA or HO rear bar so my question is it gonna be safe to run it with out the HA or the HO rear bar? My other question is which bushing and end links do i need to use does any one have a part number for those parts? Thanks for all the help.
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 02-06-2004, 05:06 PM
AutocroSSer
Guest
 
Posts: n/a
Post

It'll work fine with the stock rear bar....in fact, given your car setup (power, tranny and posi-wise) you'd probably find the HA or HO rear bar is too big.

You need the 1.25" GREASABLE Energy Suspension swaybar bushings, as well as new bolts (from GM) for those bushings. I'd also replace the endlinks while you're in there.
post #3 of 6 (permalink) Old 02-06-2004, 05:57 PM
LT4SS
Guest
 
Posts: n/a
Post

Thanks for the reply Ed, one more question, the bolts and the end links do they have to be for the WS6 or the impala one's will work? Thanks allot.
 
post #4 of 6 (permalink) Old 02-06-2004, 06:04 PM
AutocroSSer
Guest
 
Posts: n/a
Post

Bolts : Impala ones

Endlinks : take off the ones you have now, and goto the parts store (AZ in Huntsville should have them). Match up and get the closest length ones you can to what you have now. When you reinstall, do so with the weight of the car ON the suspension and torque them down to 15 ft-lbs.
post #5 of 6 (permalink) Old 02-08-2004, 03:52 PM
SSlumpin Imp
Guest
 
Posts: n/a
Post

Hey man. Its perfectly fine to run the WS6 swaybar in front with stock swaybar in the rear. That's what i'm running right now and its fine. I'm using 1LE endlinks and you do need to buy the 4 new bolts to install the bar.

check out the tech articles at theherd.com
helped me out a lot. Good luck
post #6 of 6 (permalink) Old 02-09-2004, 12:08 AM
LT4SS
Guest
 
Posts: n/a
Post

Quote:
Originally posted by SSlumpin Imp:
Hey man. Its perfectly fine to run the WS6 swaybar in front with stock swaybar in the rear. That's what i'm running right now and its fine. I'm using 1LE endlinks and you do need to buy the 4 new bolts to install the bar.

check out the tech articles at theherd.com
helped me out a lot. Good luck
Yes that really help thanks allot.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome