Moog centerlink install ?/problem..Help! - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 02-23-2002, 03:59 PM
FlatHappy
Guest
 
Posts: n/a
Post

I'm in the middle of installing Moog inner/outer tie rods, centerlink, and idler arm. I've got it all on the car and where it needs to be, but I'm having trouble getting the centerlink to seat properly with the pitman arm and idler arm. How do you get the centerlink to seat correctly? I'm trying to draw it tight with the nuts but I don't want to push my luck too far. Do I need a gear installer or something similar? Basically, what's the trick? Thanks for the help.
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 02-23-2002, 04:44 PM
Navy Lifer
Guest
 
Posts: n/a
Post

Alan,

Get a STANDARD--non self-locking type--nut, and use that to draw the tapered stud into its seat first. Then remove that nut and install the specific nut provided with the center link.

This has worked for me in the past--let us know if it works for you!
post #3 of 7 (permalink) Old 02-23-2002, 05:25 PM
FlatHappy
Guest
 
Posts: n/a
Post

Thanks for the advice Bill. I tried it out on the idler arm side but the nut I used stipped before bringing the centerlink to seat. I decided not to try on the pitman arm side. I just hope I have the pitman arm side seated enough so I can drive it to the alignment shop. With the castle nut on there it may be OK.

Thanks again.
 
post #4 of 7 (permalink) Old 02-23-2002, 06:25 PM
2SSJIM
Guest
 
Posts: n/a
Post

I use a C-clamp to squeeze them together so the stud doesn't turn. I have done several this way, and it works everytime.
post #5 of 7 (permalink) Old 02-23-2002, 06:52 PM
jerryb
Guest
 
Posts: n/a
Post

Are you sure you dont have the centerlink upside down? I just did the same thing you are doing last week and didnt have any problems with using the nut to tighten it up.
post #6 of 7 (permalink) Old 02-23-2002, 08:15 PM
FlatHappy
Guest
 
Posts: n/a
Post

2SSJIM, I can't get my c-clamp to work. stupid thing slips off. I didn't have a problem with the studs on the centerlink twisting. I just can't draw the centerlink up to seat all the way.

jerry95, it's in there the correct way (meaning not upside down). Everything is exactly like the setup I took out (and is still together).

one mistake I made was I used a locking type nut instead of following Bill's advice (stupid me). Does the non-locking type nut have stronger threads? I guess I'm just afraid of stripping the treads on the centerlink studs now. Then I'm in big trouble .

I appreciate your help. I did move the car out of the garage and it steers awesome now. Just need to seat the centerlink though. Thanks, Alan
post #7 of 7 (permalink) Old 02-23-2002, 09:09 PM
2SSJIM
Guest
 
Posts: n/a
Post

By positioning the C-clamp beside the stud and easing it up into place, it will work. Or if You have a very large set of channell lock pliers you can squeeze it together with one hand and tighten the nut with the other. Good Luck
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome