clifford alarms - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 12-02-2006, 03:13 AM
mr.SuperSport
Guest
 
Posts: n/a
Angry

Man clifford alarms is suspect very suspect i have a clifford rsx 3.5 alarm with auto start and engine lock and trunk pop paid $500 for it right. Man some punks broke into my car stole my in dash tv screen, popped my trunk i guess they thought i had some subs but they found my pair of jordans i only wore one time and stole them the whole time im in the club and my chirper is suppose to beep and vibrate when its getting broke into so because of that i got my tv and my j's stolen. Thanks alot clifford alarms. [img]graemlins/1.gif[/img]
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 12-02-2006, 05:49 AM
HACK
Guest
 
Posts: n/a
Post

Please don't take this as being a jerk, but did you remember to arm it? Was it in Valet Mode? Also depends on the shop that installed it. Most shops will hook up the trunk pop but not put a pin switch in for the trunk or hood. Did they open a door or just break a window?

Clifford has been around forever, good alarms. They have been bought out by Viper and that has made them even better.
post #3 of 7 (permalink) Old 12-02-2006, 07:19 PM
chevmdnss
Guest
 
Posts: n/a
Post

I'm with Hack on this. Sounds like it wasn't installed correctly if they got to the interior. The trunk could be just what he said........ no pin switch. Quite the norm unless you ask for it.
 
post #4 of 7 (permalink) Old 12-03-2006, 02:23 PM
poohizzle
Guest
 
Posts: n/a
Post

as far as the trunk issue i have the 791xv VIPER and i put the the trunk pop on it but later realized if ur going to invest in an alarm or trunk gear protect it after that i put in a hood pin.... u feel violated dont u????????sorry about the lost...
post #5 of 7 (permalink) Old 12-03-2006, 02:28 PM
UndercoverPunk
Guest
 
Posts: n/a
Post

2 way paging alarms only work if you're in range. If I'm in somewhere I hit the status button on my alarm just to see if I'm in range.

I also would like to know the details of how they got in. Theft deturrent is a huge deal to me.
post #6 of 7 (permalink) Old 12-06-2006, 07:49 PM
Guest
 
Posts: n/a
Post

^^^^^^^ what he said.


If you were out of range and or the building was made of something that weakened the signal (metal structure) it wouldnt work. Also did you have metalized tint on your car? Sungate windshield? That will also weaken the signal up some.

Suck I know been down that same road before. In all honesty the best security is a insurance company that will cover all your belongings. And never leave your car where you cant see it.

Since my caprice got stolen I learned a hard lesson. I never take my impala anyway that I cant see it. So clubs, car shows, concerts, hotels, extended trips in the mall are all out of the question.
post #7 of 7 (permalink) Old 12-09-2006, 10:50 PM
94fleet
Guest
 
Posts: n/a
Post

Is there any way to test the alarm, use a key to open the trunk while the alarm is on?

I have a Clifford Alarm, and the stock alarm still working in tandem. If I want to use the stock alarm I have to press the lock button on one of the doors, I can also activate the Clifford alarm, I set them off in tandem the other day, I had the siren going, then the horn going as well.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome