Cool Disabler - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-14-2006, 07:23 AM
Tim
Guest
 
Posts: n/a
Post

Anyone have any opinions or have one of these installed? http://www.neverstolen.com/

I'm considering it seriously as an add-on to my other theif deterrents. I'm hoping the more it's a PITA for them to get my car started, the better chance I have of them giving up.
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-15-2006, 09:48 AM
Dean Barnholdt
Guest
 
Posts: n/a
Post

sorry did I miss their selling price somewhere or would I have to go to the "GM dealer/stealers" to get it?

Dean
post #3 of 6 (permalink) Old 07-15-2006, 10:14 AM
chevmdnss
Guest
 
Posts: n/a
Post

email them and see what they say.
 
post #4 of 6 (permalink) Old 07-15-2006, 04:16 PM
sherlock9c1
Guest
 
Posts: n/a
Post

I don't see what's so special here - yeah so they got some fancypants plug on the dash - that has to go back to a module (which you hide) somewhere, which then interrupts ignition, starter, fuel, you pick. I don't see how this is soooo much more better (yes, I said mo better) than anything else out there. If I was a thief, I'd follow that nice armored cable back to the box or wherever the connections are, jumper the connections, and be on my way. Their website didn't show me anything I haven't seen elsewhere. Am I missing something?
post #5 of 6 (permalink) Old 07-19-2006, 12:22 AM
Aerometor
Guest
 
Posts: n/a
Post

"All electrical connections are made in the engine compartment and are connected in and through the factory wiring harnesses. Since there are no exposed wires, a properly installed Ravelco is virtually impossible to detect and very time consuming to trace, because all the wires are the same color (black)."
post #6 of 6 (permalink) Old 07-19-2006, 12:38 PM
sshogun
Guest
 
Posts: n/a
Post

I have something similar on my Durango, it was there when I bought it. Not sure if it works though, never had someone try and steal her ,I dont think but I soetimes forget I unplugged it and try and start the ignitionand theres dead silence. [img]smile.gif[/img]
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome