Water temp gage sensor - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 12-03-2015, 07:59 AM Thread Starter
Senior Member
 
6 speed V's Avatar
 
Join Date: Feb 2010
Location: Dover, De
Posts: 293
 
Water temp gage sensor

Looking for a good part number or replacement for the gauge sensor, in the right cylinder head, and connector if possible. Tore mine up doing header swap.

Thanks

Mike

Last edited by 6 speed V; 12-03-2015 at 09:29 AM.
6 speed V is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 12-03-2015, 08:34 AM
Senior Member
 
4DoorSS's Avatar
 
Join Date: Nov 2008
Location: Beautiful Chester County, PA
Posts: 7,974
 
This Sticky has all the part numbers you would probably need. I think it was on the 2nd page that had the Gauge Sensor...

https://www.impalassforum.com/vBullet...d.php?t=227215

Those are GM numbers that you could cross reference if you want to go aftermarket. Most sites, like Autozone or Advance you can go to and enter all the info and find the part number they offer for the sensor. I've used duralast brand sensors for years without issue....usually in stock and cheaper than GM.

================================================== =============


'95 Caprice SS conversion - Bonny Buckets - 96 Column, Shifter and Console - 3.73 Gear and Herter tune - Z/28 Cluster - Blazer OH Console - Green/Pink bushings - Chromed Impala Wheels - Eibach Springs and Bilstein Shocks - Corvette Engine Dress - the list goes on and still more to do...it never ends.
4DoorSS is offline  
post #3 of 7 (permalink) Old 12-03-2015, 08:47 AM Thread Starter
Senior Member
 
6 speed V's Avatar
 
Join Date: Feb 2010
Location: Dover, De
Posts: 293
 
Quote:
Originally Posted by 4DoorSS View Post
This Sticky has all the part numbers you would probably need. I think it was on the 2nd page that had the Gauge Sensor...

https://www.impalassforum.com/vBullet...d.php?t=227215

Those are GM numbers that you could cross reference if you want to go aftermarket. Most sites, like Autozone or Advance you can go to and enter all the info and find the part number they offer for the sensor. I've used duralast brand sensors for years without issue....usually in stock and cheaper than GM.

Now riddle me this: I have the Z-28 dash swap (I did not do it). Will the sender in the head be different, will I need a F-Body sender??

And Thanks for the info!!

Mike

Last edited by 6 speed V; 12-03-2015 at 08:49 AM.
6 speed V is offline  
 
post #4 of 7 (permalink) Old 12-03-2015, 09:07 AM
Senior Member
 
4DoorSS's Avatar
 
Join Date: Nov 2008
Location: Beautiful Chester County, PA
Posts: 7,974
 
Quote:
Originally Posted by 6 speed V View Post
Now riddle me this: I have the Z-28 dash swap (I did not do it). Will the sender in the head be different, will I need a F-Body sender??

And Thanks for the info!!

Mike
Right there with you as I also have the Z Cluster in my 95. When I did the swap, I did NOT replace the Sensor for the gauge and it seems to work within range. Now if we're talking Oil Pressure sensor, that's a whole nuther discussion.

Can't remember if the install instructions for the Cluster touched on this or not, but the Caprice Coolant Sensor works fine in my setup. You could just for the heck of it look up the part number for both and LT1 in a Camaro and Caprice/Impala to see if they are different. I suspect they are both the same, but if different, I would not worry about it.

================================================== =============


'95 Caprice SS conversion - Bonny Buckets - 96 Column, Shifter and Console - 3.73 Gear and Herter tune - Z/28 Cluster - Blazer OH Console - Green/Pink bushings - Chromed Impala Wheels - Eibach Springs and Bilstein Shocks - Corvette Engine Dress - the list goes on and still more to do...it never ends.
4DoorSS is offline  
post #5 of 7 (permalink) Old 12-03-2015, 09:23 AM Thread Starter
Senior Member
 
6 speed V's Avatar
 
Join Date: Feb 2010
Location: Dover, De
Posts: 293
 
Quote:
Originally Posted by 4DoorSS View Post
Right there with you as I also have the Z Cluster in my 95. When I did the swap, I did NOT replace the Sensor for the gauge and it seems to work within range. Now if we're talking Oil Pressure sensor, that's a whole nuther discussion.

Can't remember if the install instructions for the Cluster touched on this or not, but the Caprice Coolant Sensor works fine in my setup. You could just for the heck of it look up the part number for both and LT1 in a Camaro and Caprice/Impala to see if they are different. I suspect they are both the same, but if different, I would not worry about it.
Ok sounds good I might hit the dealer up today see what I can find, and we chatted a few years ago at Carlisle.

Thanks

Mike
6 speed V is offline  
post #6 of 7 (permalink) Old 12-05-2015, 02:18 PM
Senior Member
 
4x4high's Avatar
 
Join Date: Jan 2012
Location: Fremont, Ca.
Posts: 1,621
 
Garage
Send a message via Yahoo to 4x4high
I just replaced mine in my 96 Impala from Napa and it is part number TS4019.

1996 DGGM Impala SS
4x4high is offline  
post #7 of 7 (permalink) Old 12-07-2015, 07:05 AM Thread Starter
Senior Member
 
6 speed V's Avatar
 
Join Date: Feb 2010
Location: Dover, De
Posts: 293
 
Quote:
Originally Posted by 4x4high View Post
I just replaced mine in my 96 Impala from Napa and it is part number TS4019.
Thanks for everyone's help and input, I went to the dealer and got the sender and connector, worked like a champ, and even got a discount.

Mike
6 speed V is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome