95 antenna won't 'park' - Chevy Impala SS Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 02-22-2018, 11:42 AM Thread Starter
Senior Member
 
Join Date: Dec 2004
Location: Pearland, Texas
Posts: 586
 
95 antenna won't 'park'

It's been a while since I've been here! Good, I guess to be back. We've sold the 95 9C1 to a guy who was wanting a rust-free 9C1 to replace his rusting box 9C1, but still have the 95 DGGM and 96 BBB. They're both mostly garage queens now, with the DGGM usually only coming out for inspections.

During the last road trip (to get an inspection), when we were putting the car away, we noticed that the antenna didn't fully-retract. It is now sitting at the normal 'ready' position, and goes up and back down to this 'ready' position when I turn the radio on and off. It won't go completely down, however, when I turn the key off.

I'd like to get this issue fixed, especially since the car is otherwise in pretty good shape with 22K miles on the clock. Can I get some direction on where to look? Is it in the antenna assembly, or some relay? Thanks!

Gene Beaird
95 DGGM SSSS, HAIL
96 BBB SSSS, HAIL 'WarPig'
2012 9C1 Caprice (my DD)
2010 Tahoe PPV (her DD)
92 B4C 1LE Camaro
85 Firebird, SCCA CP Solo II - 310 cu. in. LS1/TH350/Moser 9"
95 381 LT4/6SP Z28 Vert - 405 RWHP (Her Car)
Pearland, Texas
Gene Beaird is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 02-22-2018, 07:40 PM
Senior Member
 
Z09B4U's Avatar
 
Join Date: Jul 2015
Location: Canada
Posts: 846
 
I think you will have to take the power antenna apart.

Best link I know of:

GRAIL - Power Antenna R&R

Z09B4U
Z09B4U is offline  
post #3 of 18 (permalink) Old 02-23-2018, 07:07 AM
Senior Member
 
Join Date: Jan 2001
Location: St. Louis
Posts: 7,696
 
Ftf

First things first. If mast is PERFECTLY NOT bent, and if it has been slathered with WD40, and if then cycled 15 times to loosen all black road grime, and then wiped dry and another 10 cycles with the rag each time, THEN you can move to that scary detailed R&R.

I've had luck in similar symptoms just jambing down the stalk to fully seated and pulling fully extended after it extends itself to work past built-up grime. It almost seems like the coiling plastic drive rack gets out of kilter with the pinion gear timing. The last inch of pushing down or pulling out has never seemed to hurt anything. I'm going with dirt and lube first.

\'96SS SOB: SSRI, Herter Tune, Tri-Y II, , 3000 Edge, F/HO bars, METCO extendeds with CV MMC, Bilsteins, currently Vredestein Ultrac Sessanta (315/35 rear). Finally, wait for it... LT-4 knock module!
\'96FWB BUW-Butt Ugly White: PCMPerformance tune, HDFA w/ swissed filter, 1/2 SLP s.s. catback with H- and Flow Super 50s, oem opti rebuilt 3 times, SS Bars, METCO LCA, Airlift 1000, Monroe SS, PowerTrax No-Slip, CTS wheels with +1 rubber. Finally, yes again... LT-4 knock module!
96 Black is offline  
 
post #4 of 18 (permalink) Old 02-23-2018, 07:10 AM
Senior Member
 
Fred Kiehl's Avatar
 
Join Date: Feb 2009
Location: Largo, FL 33774
Posts: 10,868
 
You probably need a new cable, or the limit switch has some dried grease on it, making actuate early.

1991 OCC 461 (.030 over 454) BBC, 3.23 posi, flash to pass, drop spindles & springs, Impala rims, Hydroboost, Recaros, MOMO/wood SW w/QR, custom wood shift knob, Pioneer DEH P77DH
1992 OCC now with 5.7 tbi, DEH P77DH
For a parts list, check https://www.impalassforum.com/vBulle...ion-parts.html
Fred Kiehl is offline  
post #5 of 18 (permalink) Old 02-23-2018, 08:05 AM Thread Starter
Senior Member
 
Join Date: Dec 2004
Location: Pearland, Texas
Posts: 586
 
I'll probably start at the limit switch. The antenna is _perfectly_ straight and clean. The car has 22,000 miles on the clock, and pretty much all of that has been in good weather, and always garage-kept when not on the road. The mast is clean and waxed.

We tried putting a little downward pressure on the mast as I turned the radio on and off, and again when I turned the key off. That did nothing.

Gene Beaird
95 DGGM SSSS, HAIL
96 BBB SSSS, HAIL 'WarPig'
2012 9C1 Caprice (my DD)
2010 Tahoe PPV (her DD)
92 B4C 1LE Camaro
85 Firebird, SCCA CP Solo II - 310 cu. in. LS1/TH350/Moser 9"
95 381 LT4/6SP Z28 Vert - 405 RWHP (Her Car)
Pearland, Texas
Gene Beaird is offline  
post #6 of 18 (permalink) Old 02-23-2018, 10:19 AM
Senior Member
 
Z09B4U's Avatar
 
Join Date: Jul 2015
Location: Canada
Posts: 846
 
Quote:
the limit switch has some dried grease on it, making actuate early.
Texas dried grease was my guess. I find this also in windshield wiper assemblies.

FSM says do not lube.

https://www.impalassforum.com/vBullet...r-antenna.html

More help from Fred in these links:

https://www.impalassforum.com/vBullet...epair-who.html

https://www.impalassforum.com/vBullet...r-antenna.html

Z09B4U
Z09B4U is offline  
post #7 of 18 (permalink) Old 02-23-2018, 06:41 PM
Banned
 
Join Date: Oct 2009
Location: northeast
Posts: 3,437
 
I do not like these GM antennas.. these are a very old design that does break .. so when you start the vehicle radio on the antenna works way to much for this design that cannot handle the work .

so having had these issues with 1980 GM vehicles I got the96 impala day one 23 miles on it started engine radio on open the hood disconnect the antenna connector deal is done..

2 months ago I had to bring vehicle to body shop for some paint work ... engine off ,, wiped down the antenna mast with a good amount of silicone lube , plugged in the antenna connector ,,, antenna dropped like it had when 23 miles was on it ..

your in Texas an area that can get ice out .. up in the cold north east these antennas will fail the first ice storm ... very weak so it is always up unless it is going to get some body shop work done which is not all that often .. IMO perhaps 10 times since 23 miles on it that I had to drop the mast.

I have taken them apart contacts very possible burned up or the motor or the nylon rod...
j cat is offline  
post #8 of 18 (permalink) Old 02-23-2018, 09:51 PM
Senior Member
 
Fred Kiehl's Avatar
 
Join Date: Feb 2009
Location: Largo, FL 33774
Posts: 10,868
 
I have a Caprice/wagon antenna for sale for $80. It is retracted (a good sign). I have not checked it, but I will if someone is interested in it.

1991 OCC 461 (.030 over 454) BBC, 3.23 posi, flash to pass, drop spindles & springs, Impala rims, Hydroboost, Recaros, MOMO/wood SW w/QR, custom wood shift knob, Pioneer DEH P77DH
1992 OCC now with 5.7 tbi, DEH P77DH
For a parts list, check https://www.impalassforum.com/vBulle...ion-parts.html
Fred Kiehl is offline  
post #9 of 18 (permalink) Old 02-24-2018, 07:41 AM Thread Starter
Senior Member
 
Join Date: Dec 2004
Location: Pearland, Texas
Posts: 586
 
Thank you, Fred. I also think I have a 96 SS antenna around here, also fully-retracted, in my stash-O-spares. It, however, spent some time outside under a tree with the rest of the front clip for a while. I'll have to check it, too.

Gene Beaird
95 DGGM SSSS, HAIL
96 BBB SSSS, HAIL 'WarPig'
2012 9C1 Caprice (my DD)
2010 Tahoe PPV (her DD)
92 B4C 1LE Camaro
85 Firebird, SCCA CP Solo II - 310 cu. in. LS1/TH350/Moser 9"
95 381 LT4/6SP Z28 Vert - 405 RWHP (Her Car)
Pearland, Texas
Gene Beaird is offline  
post #10 of 18 (permalink) Old 02-25-2018, 03:29 PM Thread Starter
Senior Member
 
Join Date: Dec 2004
Location: Pearland, Texas
Posts: 586
 
Spent a little quality time with the SS this afternoon. The antenna mast is dead-straight. It looks like, though, it is not actually going to the 'power-on' parked position, but stopping with about 14" of mast exposed. It seems to go up fine, and retracts to this point, and this point only.

I'm assuming here that if it is going up and down, at least partially, the relay should be fine? If not, how the heck do you remove it?!? It looks like it's part of the electrical center, with a plug that plugs into the firewall-side of the relay. I didn't see a way to pull just the relay, but I only had my phone light, and was standing on my head under the dash as I was working there.

I also spent some time trying to find that other antenna assembly, but some of the storage containers are towards the top of our shelving, and my tall ladder was still in the garage, so we can cover the orange trees in case of another freeze. Between the two is about 250' of waterlogged yard, so I could neither walk it out there, nor drive it out there, for now.

Gene Beaird
95 DGGM SSSS, HAIL
96 BBB SSSS, HAIL 'WarPig'
2012 9C1 Caprice (my DD)
2010 Tahoe PPV (her DD)
92 B4C 1LE Camaro
85 Firebird, SCCA CP Solo II - 310 cu. in. LS1/TH350/Moser 9"
95 381 LT4/6SP Z28 Vert - 405 RWHP (Her Car)
Pearland, Texas

Last edited by Gene Beaird; 02-25-2018 at 03:31 PM.
Gene Beaird is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome