Lack of dash and running lights - Chevy Impala SS Forum
 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 41 (permalink) Old 01-06-2019, 08:47 AM Thread Starter
Junior Member
 
Swtgrl2no's Avatar
 
Join Date: Jan 2019
Posts: 20
 
Lack of dash and running lights

Hi , so.. (1996 caprice 4.3) day before yesterday I lost my dash and running lights. All other lights are working no prob. Fuses are good but not getting power to 41 42 and 43. I am thinking its perhaps the headlight switch. That presents two problems. 1 ripping into 3/4 of the dash to get to it and 2 NO ONE has one! Its discontinued and even no longer aftermarket! Anyone have a testing and repair procedure? I have basic lights not twilight sentinel and not dtr. Switch pic below. Thanks so much for any help.
Attached Thumbnails
Click image for larger version

Name:	20190104_130945_1546786037456.jpg
Views:	25
Size:	367.6 KB
ID:	180842  

Swtgrl2no is offline  
Sponsored Links
Advertisement
 
post #2 of 41 (permalink) Old 01-06-2019, 10:23 AM
Senior Member
 
Join Date: Jan 2001
Location: St. Louis
Posts: 7,641
 
Fair to large number of hits with "no dash lights" - I assume you checked those already. Multiple threads reference simul. dash/tail probs. It took this guy over 2 weeks but he finally resolved similar issue(s):
https://www.impalassforum.com/vBulle...il-lights.html) It took
j cat likes this.

\'96SS SOB: SSRI, Herter Tune, Tri-Y II, , 3000 Edge, F/HO bars, METCO extendeds with CV MMC, Bilsteins, currently Vredestein Ultrac Sessanta (315/35 rear). Finally, wait for it... LT-4 knock module!
\'96FWB BUW-Butt Ugly White: PCMPerformance tune, HDFA w/ swissed filter, 1/2 SLP s.s. catback with H- and Flow Super 50s, oem opti rebuilt 3 times, SS Bars, METCO LCA, Airlift 1000, Monroe SS, PowerTrax No-Slip, CTS wheels with +1 rubber. Finally, yes again... LT-4 knock module!
96 Black is offline  
post #3 of 41 (permalink) Old 01-06-2019, 10:45 AM Thread Starter
Junior Member
 
Swtgrl2no's Avatar
 
Join Date: Jan 2019
Posts: 20
 
Yes a week of scouring the internet the library. Probing and poking wires all but pulling the dash apart. 98% of what I found spoke of twilight sentinel and dtr neither of which I have. As for trying a new switch that seams impossible as none can be found! All fuses test good. No power to mentioned fuses.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20190105-100822_Gallery_1546793111590.jpg
Views:	24
Size:	197.4 KB
ID:	180844  

Swtgrl2no is offline  
 
post #4 of 41 (permalink) Old 01-06-2019, 12:06 PM
Senior Member
 
gbhs72's Avatar
 
Join Date: Nov 2015
Location: Lawton, Ok
Posts: 1,440
 
If it is the head light switch, Rock Auto has 2 of them. They are pricey. https://www.rockauto.com/en/moreinfo...037494&jsn=482

Mark: Snowman-33

93 9C1: Work & Cubic Ca$h This started with a new headlight and fender Celeritas In Conficiendo
gbhs72 is offline  
post #5 of 41 (permalink) Old 01-06-2019, 12:21 PM Thread Starter
Junior Member
 
Swtgrl2no's Avatar
 
Join Date: Jan 2019
Posts: 20
 
Yeah OUCH! now I definitely want a way to test before I make that plunge. Oreily showed they could get same ones but turned out they couldn't. Hopefully it's not the same for rockauto.
Swtgrl2no is offline  
post #6 of 41 (permalink) Old 01-06-2019, 12:27 PM
Senior Member
 
Z09B4U's Avatar
 
Join Date: Jul 2015
Location: Canada
Posts: 832
 
Quote:
98% of what I found spoke of twilight sentinel and dtr neither of which I have.
The TW circuit can be ignored if you do not have it.


The 1994 diagram is different than the 1996 I am looking at.

You did not mention anything about Fuse#31 which powers the tail light and instrument lamp fuses. These are the only two fuses connected to #31 in the 96 diagram.


Goldswagon Wiring Diagrams


Look at the headlamp DLR or Twilight, external, and instrument diagrams.



Quote:
Fuses are good but not getting power to 41 42 and 43
Are you looking at the right circuit diagram or fuse box diagram? The 1996 seems to be different.


I just pulled out a 1996 Owners manual. I see it shows 41,42, and 43. Does not match with Goldswagon diagram.


For 94-96 it seems that these fuses are supplied by #31.

Z09B4U

Last edited by Z09B4U; 01-06-2019 at 12:50 PM.
Z09B4U is offline  
post #7 of 41 (permalink) Old 01-06-2019, 01:32 PM
Senior Member
 
Join Date: Jan 2001
Location: St. Louis
Posts: 7,641
 
Quote:
Originally Posted by Z09B4U View Post
.....
You did not mention anything about Fuse#31 which powers the tail light and instrument lamp fuses. These are the only two fuses connected to #31 in the 96 diagram.

........

That's more what I was driving at. The OP may not presume to walk around the back of the car if the dash/running are out. No power to the first mentioned fuses may be fed from an upstream block fuse. That's what I was half-conjecturating from the thread I linked up there.



Final thought - I'd be hunting slightly earlier work on the car that may have messed up a ground, or, find those upstream fuses/breakers/relays whatever, v. zooming in on the switch. Sure they go bad, but unless some special abuse/overuse the other stuff's more probable.

\'96SS SOB: SSRI, Herter Tune, Tri-Y II, , 3000 Edge, F/HO bars, METCO extendeds with CV MMC, Bilsteins, currently Vredestein Ultrac Sessanta (315/35 rear). Finally, wait for it... LT-4 knock module!
\'96FWB BUW-Butt Ugly White: PCMPerformance tune, HDFA w/ swissed filter, 1/2 SLP s.s. catback with H- and Flow Super 50s, oem opti rebuilt 3 times, SS Bars, METCO LCA, Airlift 1000, Monroe SS, PowerTrax No-Slip, CTS wheels with +1 rubber. Finally, yes again... LT-4 knock module!
96 Black is offline  
post #8 of 41 (permalink) Old 01-06-2019, 01:37 PM
Banned
 
Join Date: Oct 2009
Location: northeast
Posts: 3,437
 
Quote:
Originally Posted by Swtgrl2no View Post
Hi , so.. (1996 caprice 4.3) day before yesterday I lost my dash and running lights. All other lights are working no prob. Fuses are good but not getting power to 41 42 and 43. I am thinking its perhaps the headlight switch. That presents two problems. 1 ripping into 3/4 of the dash to get to it and 2 NO ONE has one! Its discontinued and even no longer aftermarket! Anyone have a testing and repair procedure? I have basic lights not twilight sentinel and not dtr. Switch pic below. Thanks so much for any help.
no power to the fuses 41/42/43 .. you have no park lamps working but the headlamps work so with my work looking this up on my OEM 1996 B body diagram the fuse maybe #31 label ext LPS fuse 20amp.

now if you had no headlamps "also" then it would be the fuseable link A..that feeds both park and headlamp power to the operator dash control switch .. good luck ..

If I posted the diagram forum would dump it quickly ..
j cat is offline  
post #9 of 41 (permalink) Old 01-06-2019, 03:36 PM Thread Starter
Junior Member
 
Swtgrl2no's Avatar
 
Join Date: Jan 2019
Posts: 20
 
That fuse looks fine too.. I'm going to try replacing it and see.. ya know the ol looks fine but still bad
Swtgrl2no is offline  
post #10 of 41 (permalink) Old 01-06-2019, 04:24 PM
Senior Member
 
Z09B4U's Avatar
 
Join Date: Jul 2015
Location: Canada
Posts: 832
 
Quote:
That fuse looks fine too.. I'm going to try replacing it and see.. ya know the ol looks fine but still bad

You are wasting time without a test light or voltmeter.


Fuse #31 is fed by a fusible link. The horn is fed by the same fusible link(as per Goldwagon's diagram). Does your horn work? If it was a 94 I would ask you if your headlights worked.



There is no point in testing anything else unless you verify voltage on both sides of fuse #31. You cannot blame the headlight switch if it is not getting power.

Z09B4U
Z09B4U is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome