Twilight Sentinel repair - Page 2 - Chevy Impala SS Forum
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 71 (permalink) Old 03-23-2010, 01:41 AM
Senior Member
 
Join Date: Feb 2010
Location: Tennessee
Posts: 244
 
Thats cool. I am going to check mine again and make sure I was working it right.

If dont work I am going to try to locate that box and replace it. I will just have to find out its location on the 1991 model.
Tennesseestorm is offline  
Sponsored Links
Advertisement
 
post #12 of 71 (permalink) Old 03-23-2010, 09:15 AM Thread Starter
Senior Member
 
95BRMW's Avatar
 
Join Date: Mar 2008
Location: CT
Posts: 1,461
 
Quote:
Originally Posted by Tennesseestorm View Post
Thats cool. I am going to check mine again and make sure I was working it right.

If dont work I am going to try to locate that box and replace it. I will just have to find out its location on the 1991 model.
I would think its on the steering column in yours.

1996 DCM SS 216k
1996 Black RMW 158k
1995 DCM Roadmaster Wagon 118K
1992 Olds CC 5.3l LS swap 181k
1994 Fleetwood 160k
1975 Impala Coupe

95BRMW is offline  
post #13 of 71 (permalink) Old 03-25-2010, 09:54 PM
Senior Member
 
Join Date: Feb 2010
Location: Tennessee
Posts: 244
 
Thanks for that info. Good news is that my twilight actually works. I didnt have the car on / switch on when setting. Oh well.
Tennesseestorm is offline  
 
post #14 of 71 (permalink) Old 03-29-2010, 08:09 PM
Junior Member
 
Join Date: Mar 2010
Posts: 3
 
Thanks so much!

I just drove the car home last night and was annoyed that the Twilight Sentinal wasn't working. And this fix worked! I'm so excited

Rob
Gvr4-330 is offline  
post #15 of 71 (permalink) Old 03-29-2010, 09:06 PM
Senior Member
 
Buffman's Avatar
 
Join Date: Jul 2003
Location: Michigan
Posts: 11,013
 
Send a message via AIM to Buffman
That's what was wrong with mine. two solder joints. Re-soldered and it's still working

Matt Hoffman


Exhaust Video Burnout!! New Quick Video!
ET: 13.5272 @99.33mph 1.82 60'

^^ Gone 7/12/09, but not forgotten
Buffman is offline  
post #16 of 71 (permalink) Old 03-29-2010, 09:10 PM
Senior Member
 
Join Date: Feb 2010
Location: Tennessee
Posts: 244
 
Thats great! I was happy when mine started working... mine was not broken though... only the user was too dumb to know how to set it. lol. I didnt have the car/switch on when setting it.
Tennesseestorm is offline  
post #17 of 71 (permalink) Old 08-12-2010, 08:33 PM
Member
 
bsifast's Avatar
 
Join Date: Jun 2005
Location: Petaluma CA
Posts: 46
 
that part you're soldering....do you know the part# for it?

Almost done '96. Oh! Come on- we're never DONE!
bsifast is offline  
post #18 of 71 (permalink) Old 08-23-2010, 05:55 PM
Member
 
bsifast's Avatar
 
Join Date: Jun 2005
Location: Petaluma CA
Posts: 46
 
searched the CDRom '91-'96 parts catalog.
Is 10076724 the part# for this relay?
Anybody?
Some of you guy's have had it out to solder it, right?
and someone said they had a spare, right?
Is the part # on it?
any help is appreciated.

Almost done '96. Oh! Come on- we're never DONE!
bsifast is offline  
post #19 of 71 (permalink) Old 08-25-2010, 06:59 AM
Junior Member
 
Join Date: Dec 2009
Location: St. Louis area
Posts: 15
 
Yes that is what I have for the part number.
The soldering fix worked pretty well in mine.
Looks like GM Parts Giant has one, for $73.08,
but you never know until you try to buy it.
markamon is offline  
post #20 of 71 (permalink) Old 08-31-2010, 08:10 PM
Member
 
bsifast's Avatar
 
Join Date: Jun 2005
Location: Petaluma CA
Posts: 46
 
did this fix today and all is well!
and I learned how to solder, too!
thanks to this thread and all who chimed in!

Almost done '96. Oh! Come on- we're never DONE!
bsifast is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome