neverending ... need help - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-10-2012, 04:15 PM Thread Starter
Junior Member
 
Gina's Avatar
 
Join Date: Oct 2010
Location: High Desert, California
Posts: 25
 
neverending ... need help

so my ABS light went on a week or so ago on my 94 roadmaster (yes it's cut on hydraulics) then today I went driving went to park the car turned the key to the off position and the motor was still running (entire car was on actually gauge cluster etc) even took the key out of the ignition still on. I had to pull the fuse under the hood for the ignition and disconnect my battery looking under the hood under my intake and where my MAF sensor sits right on top of melted wire mess leading into what looks like the ABS module ???? I took a pic of it I can't find it in my repair manual and have been searching online to see wtf is goin on very frustrated to say the least right now any help would be appreciated thanks!

Gina is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome