No turn signals! but have hazards what the deal? - Chevy Impala SS Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-31-2012, 08:44 PM Thread Starter
Junior Member
 
Join Date: Oct 2012
Posts: 2
 
No turn signals! but have hazards what the deal?

My turn signals were working but they quit. The lever for the turning signal feels loose. I have hazards. And everything is fine with the brake lights. Why do the turning signals not work? Also, my speedometer cluster lights don't work. The cluster fuse keeps blowing. Could all this be a result of the same problem? Plus, could the ground for the cluster light be in the steering column.
Harley3w is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-31-2012, 10:58 PM
Senior Member
 
Fred Kiehl's Avatar
 
Join Date: Feb 2009
Location: Largo, FL 33774
Posts: 10,836
 
It could be your turn signal switch. The turn signals, and the hazards are on different circuits in the switch. The short in dash lights could be anywhere, you are going to have to troubleshoot the wire harness, or the cluster itself. A short usually occurs before the load when it blows a fuse, or the load is a short. The dimmer switch for the cluster lights could be grounding the power, because it is a potentiometer, and one side of the resistor is ground. If it is just your cluster lights that are not working, and your courtesy lights are still working, it is probably the dimmer switch.

1991 OCC 461 (.030 over 454) BBC, 3.23 posi, flash to pass, drop spindles & springs, Impala rims, Hydroboost, Recaros, MOMO/wood SW w/QR, custom wood shift knob, Pioneer DEH P77DH
1992 OCC now with 5.7 tbi, DEH P77DH
For a parts list, check https://www.impalassforum.com/vBulle...ion-parts.html
Fred Kiehl is offline  
post #3 of 3 (permalink) Old 11-01-2012, 06:51 PM Thread Starter
Junior Member
 
Join Date: Oct 2012
Posts: 2
 
Thanks soo much!! its been on my mind all day maybe ill get a little sleep tonight wiring trouble shoot isnt one of my strong points
Harley3w is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala SS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome